electrical issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > New Jersey Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-03-2012, 09:21 PM
Thread Starter
  #1
Jeeper
 
grthomas11's Avatar
 
Join Date: Jul 2010
Posts: 82
electrical issue

Ok so i need some help. My jeep is out of commission. I keep blowing a fuse. The one that keeps the jeep running. I have a 92 with the 4 banger. Any ideas?

Thanks for any help.

grthomas11 is offline   Quote
Old 01-04-2012, 05:40 AM   #2
Jeeper
 
Join Date: Aug 2011
Posts: 100
I'm not 100% sure if your computer also plays a roll as a voltage regulator or if it's within the distributor, but it is possible that an over charge will do this. If not you have a dead short somewhere like a cut wire hitting the frame or wires within the harness with worn off insulation touching each other. In order to go any further I'm going to need a better description of the fuse. Like what number it is, what circuit its actually on or a photo with an arrow pointing at the fuse.

Mudboy is offline   Quote
Old 01-07-2012, 10:43 AM
Thread Starter
  #3
Jeeper
 
grthomas11's Avatar
 
Join Date: Jul 2010
Posts: 82
I just took a picture of the fuse that keeps blowing. Any help would be great. Thanks.
Click image for larger version

Name:	fuse.jpg
Views:	57
Size:	198.2 KB
ID:	87978
grthomas11 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 electrical issue? jyeast TJ General Discussion Forum 5 12-15-2011 06:52 PM
Strange electrical issue richie894 JK General Discussion Forum 3 04-08-2011 01:17 PM
Electrical Issue tedainsworth TJ Tech Forum 1 03-16-2010 07:32 PM
Electrical issue kg4kpg TJ Tech Forum 6 05-16-2009 09:21 PM
electrical issue khenderson TJ Tech Forum 2 09-15-2005 04:38 PM





All times are GMT -5. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC