Jeep Wrangler Forum

Jeep Wrangler Forum (https://www.wranglerforum.com/)
-   TJ Tech Forum (https://www.wranglerforum.com/f210/)
-   -   Throttle Sticking Intermittently ? 2004 Jeep Rubicon (https://www.wranglerforum.com/f210/throttle-sticking-intermittently-2004-jeep-rubicon-1158185.html)

Dconnole 03-19-2015 07:23 PM

Throttle Sticking Intermittently Ė 2004 Jeep Rubicon
 
Hey all,
Iím again having another issue I canít seem to troubleshoot on my own (huge surprise!) and since everyone was so helpful in my July (2014) and February calls for help, Iím back again.
Hereís the status: 2004 Jeep TJ Rubicon with manual trans and about 140K miles on the 4.0L stocker. Other than a cold air kit, the motor is stock and well maintained. Back in July, I was having an engine surging issue that turned out to be a bad IAC sensor. Last month, The Jeepís throttle started sticking once in a while in the 1800-3000 RPM range, but only when I was driving in those RPMs (getting on the freeway, etc). Additionally, when Iíd stab the throttle, itíd drop down to idle.

I started by inspecting all the vacuum lines, and they are all connected, flexible and serviceable from what I can tell. I pulled the throttle body to inspect it, and when I returned it, it got way worse, now sticking every time I hit the gas, so I though air leak. Tore it back down, pulled the new-ish IAC, the TPS and the MAP sensor and inspected them. The IAC sensor seemed to be protruding out further than it should, and since it was under warrantee, I took it back and picked up a new TPS and MAP sensor (were not replaced prior).

So now itís 80% better, but it still sticks now and again, and stabbing the throttle releases it. Iíve also checked the cable and the foot pedal, to Iím open to ideas.

Bad CPU? Connectors? Exhaust leak? Gremlins? Democrats?

stevestloo 03-20-2015 11:17 AM

Subscribing because I am having similar problems with my 06 LJ. Sticky throttle and also P0507 "Idle Higher than Expected" code. I replaced my IAC and TPS too with no avail. Most likely a vacuum leak. Can't chase it down,.. Been suggested to check the area around the intake gasket.

Dconnole 03-20-2015 12:36 PM

Quote:

Originally Posted by stevestloo (Post 17814473)
Subscribing because I am having similar problems with my 06 LJ. Sticky throttle and also P0507 "Idle Higher than Expected" code. I replaced my IAC and TPS too with no avail. Most likely a vacuum leak. Can't chase it down,.. Been suggested to check the area around the intake gasket.

Also check the gasket that the IAC bolts into, between the throttle body and the IAC housing. Mine was torn when I did the original IAC replacement (not sure if I tore it, or if was tore). I ended up using a thin layer of RTV silicone to seal it up.

Alas, I have no code popping up on my issue. A friend suggested I look at the cable path. I re-adjusted my floor mat and carpet (event though it looked clear) and haven't had the issue this morning. We'll see if it holds through the drive home.

Dconnole 03-23-2015 02:38 PM

So update: After cutting the carpet back, and thoroughly checking the throttle cable, I came to the conclusion that the shaft that rotates the butterflys on the throttle body is causing the issue. I liberally lubed it (WD40 seems to work fine) and have since not had an issue. If that changes, I'll update.

Jerry Bransford 03-23-2015 03:08 PM

Use something besides WD-40 for lubrication... of the things WD-40 does an ok or good job at, lubrication is not one of them. In fact, WD-40 is technically classified as a solvent. Its viscosity is so thin that it provides little short-term lubrication and pretty much no long-term lubrication since it evaporates before too long.

stevestloo 03-24-2015 08:34 AM

Quote:

Originally Posted by Dconnole (Post 17816145)

Also check the gasket that the IAC bolts into, between the throttle body and the IAC housing. Mine was torn when I did the original IAC replacement (not sure if I tore it, or if was tore). I ended up using a thin layer of RTV silicone to seal it up.

Alas, I have no code popping up on my issue. A friend suggested I look at the cable path. I re-adjusted my floor mat and carpet (event though it looked clear) and haven't had the issue this morning. We'll see if it holds through the drive home.

I sprayed all areas of the throttle and all vacuum lines liberally with carb cleaner to find leaks and there were none in that area. Might be at the intake manifold gasket


All times are GMT -5. The time now is 03:59 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.