Jeep Wrangler Forum

Jeep Wrangler Forum (https://www.wranglerforum.com/)
-   TJ Tech Forum (https://www.wranglerforum.com/f210/)
-   -   04 Rubicon runs bad at idle, speedo bouncing in park (https://www.wranglerforum.com/f210/04-rubicon-runs-bad-at-idle-speedo-bouncing-in-park-29071.html)

sgblakley 04-12-2009 02:13 PM

04 Rubicon runs bad at idle, speedo bouncing in park
 
I need HELP, Yesterday my 04 rubicon starting running really bad then within 6 miles it shut off and wouldn't restart.
This morning I have replaced the TPS, the Crankshaft position sensor, the Ignition Fuse, all 6 plugs, and ignition coil. Got it to restart and running but it's running rough while still in park, the speedo is bouncing everywhere and the check engine light is on. Don't have access to a OBD II. This is my only ride, I need help. Please I know that it's Easter Sunday and most of you are with your families, I am just trying to get home today.
Thank you so much in advance...

jdhallissey 04-12-2009 02:25 PM

hey turn your truck to the on position then off 3 times in 5 seconds on the last time you cycle it on don't shut it off it will read youaset of codes. Write them down and when you get to the 55 code that means it has gone it's cycle. Tell us the codes that is was thrown. We can help more from there.

sgblakley 04-12-2009 02:53 PM

Thanks for that info, never knew about that... here are the codes that came up, P 340, P353, P352, P351, P206, P300, P302, P305...
Thanks for the Help

jdhallissey 04-12-2009 03:04 PM

yep umm PM Jerry Bradsford. He almost knows these codes by heart I don't know if he is on today or not. I can try and find them too

jtalar 04-12-2009 03:09 PM

Try Tech - TJ Error Codes - GETAHELMET.COM

jdhallissey 04-12-2009 03:11 PM

Your 302 and 305 are missfire codes cylinders 2 and 5. 351 is the ingnition coil number 1 I believe. The 352 and 353 are the ignition coils 2 and 3. The 206 I have no clue and the 340 is the cam shaft position sensor.

sgblakley 04-12-2009 03:29 PM

I have replaced the spark plugs, and the ignition coil already this morning. Any ideas as to what it could be?

jdhallissey 04-12-2009 03:33 PM

Camshaft position sensor. Pull the battery cables off then put them back on to reset the comp.

sgblakley 04-12-2009 03:45 PM

reset computer, now just P352 ignition coil B. Which is ignition coil B?

jdhallissey 04-12-2009 03:49 PM

You replaced the coil right? May want to pull your plugs real quick and check them too.

ygohome 04-12-2009 04:16 PM

when my 04 rubicon was idleing rough and the rpms were erratic the shop cleaned the carbon out with some additive in the tank and sprayed stuff in through the throttle body. that and a tune up which included changing out the spark plugs and me changing to new heavier gauge batterry cables fixed my prob. basically i just took it in to a capable mechanic and he got it running smooth again. i hate replacing random parts not knowing if its going to fix a problem or not so it's worth it to me to have a trusting mechanic diagnose it.

sgblakley 04-12-2009 08:11 PM

I have replaced the coil, and all 6 plugs. I am getting the code for Coil B as being bad, not sure which is B... The coil closest to the firewall gets extremely hot within 1 min. Thats why I am unsure of why the code for B coil...


All times are GMT -5. The time now is 03:29 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.