Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
#help
1-7 of 7 Results
  1. JK Tech Forum
    Hey Jeepers! I purchased a 2017 2D Sahara Wrangler in April. Started to experience problems in June. Currently has 66,000. First time I experienced the problem I was driving on the highway 60 mph , Rpms jumped from 2 to 4 , no acceleration paired with a grinding noise clunking noise, pulled over...
  2. JL Wrangler Technical Discussion
    Just lifted my JL with Metalcloak Dual Rate 2.5" lift with 37" Toyo Open Country MT's & 17" Icon Rebounds wheels. As soon as I got on the highway it starts bouncing, it actually started around 55+mph. Why does this happen & what can I do to stop it?
  3. JK Tech Forum
    I have a 4in lift 16 Wrangler JKU on 35s. I recently blew out the cv joint on my front drive shaft and wore out my tie rod ends & drag link. (MY FRONT DRIVE SHAFT IS STILL UNINSTALLED) I have also been hearing a clanking noise that goes faster as my tires RPM increases. I looked into it and most...
  4. JK Tech Forum
    Hello all! I just had a question that I need help with.. I have a 2015 Jeep Wrangler Sport with 33K on the ODO, is it normal for the rear differential fill plug to come out? Seems I was oblivious to even think of checking this sort of thing. As I was driving down the road the rear end locked...
  5. JK General Discussion Forum
    Hey guys I have a 2014 JEEP JK . Couple weeks ago my engine light came on code P0456. I tighten up my gas cap and the light went away but now I'm getting 10 mpg! I was wondering if anyone could give me any suggestions ? I was told maybe it could be my spark plugs. when do they need to be changed...
  6. JK General Discussion Forum
    Just bought my first Jeep on Friday!! I've been searching for seat covers that will match the Deep Water Blue. I just can't seem to find a blue that matches well. Any advice????
  7. JK General Discussion Forum
    So 3 days ago my 07 JK decided not to turn, at first I though it might be the battery, so I jumped it. only to turn it off and hour later and it did the same thing. so I proceeded to troubleshoot the terminals. everything in the battery seemed o.k so I took the battery to Auto zone. when I...
1-7 of 7 Results
Top