Jeep Wrangler Forum banner
pcm
1-18 of 57 Results
  1. TJ Tech Forum
    I have a 1999 TJ wrangler 4.0L 6Cyl Standard, it was stolen recently, the thieves broke my SKIM module and had a screwdriver jammed into my ignition cylinder. I had it brought to an auto body shop and they switched out my entire steering column but car won’t start without SKIM (or it only starts...
  2. JK General Discussion Forum
    I have a 2010 wrangler with 86k miles and the ac has not been working. Seems like a power issue to the clutch because the compressor works when I jump it and I took it to get the refrigerant emptied and the right amount put back in. Everything mechanical works fine and I got a new pressure...
  3. YJ Tech Forum
    Hi all, New to the forum but have used it for a while now and gotten a ton of valuable info so thank you all very much. I have a 1992 YJ with the 4 cylinder motor. We rescued it out of a barn and got it runnign and put a new fuel pump in it. I drove it to the gas station, ran it out of gas...
  4. JK Tech Forum
    I would really appreciate any advice here about what I'm about to do. 2014 JKU Sahara still in stock configuration except for aftermarket headlights and taillights. Long story short (I'll put the long story in a separate post), a reputable mechanic after troubleshooting my P0306 code (cylinder...
  5. TJ Tech Forum
    2000 4.0L manual transmission. Receiving the no bus message on the dash, no gages, cranks but no start. Replaced the PCM, Crank Position Sensor. Rebuilt the engine 1000 miles ago and just finished replacing the clutch so all new components including the Camshaft Position Sensor, alternator...
  6. JK Tech Forum
    Hi all. I am new here. Was searching through other posts but could not find anything pertaining my question so here it goes. Recently bought a 2012 Jeep JKU Sport with the wonderful 3.6L VVT Pentastar engine. Was having issues with the camshaft position sensor on bank 2. Located a signal wire...
  7. TJ General Discussion Forum
    Over a year ago I installed a new PCM/TCM from WranglerFix.com in to a friends '06 TJ. This was due to the hard shifting transmission issue with the dreaded P0700 trouble code. I thought it would be a good idea to follow up with the repair and see how things are working now. I posted a video...
  8. TJ Tech Forum
    I decided I was going to order a new PCM based on various bits of info and ruling out certain items. Perhaps, not the best idea I ever had, I decided to open up the existing PCM to determine if I could visually identify any damage. From what I had gathered (on the interweb), many times a bad...
  9. TJ Tech Forum
    Hello My Jeep has been at the local shop for months now. Brought in my 2005 Jeep Wrangler tj 4.0 se in for throttle body issue no rpm over 40 mph. Also had check engine light on O2 sensor heater failure and no voltage bank? Mechanic has given me tons of excuses like bad pcm, it was replaced but...
  10. JK Tech Forum
    Last year I had thrown a code for my egr (P0403) as well as for bank 2 sensor 2 heater circuit high (P0058). I took it to my old mechanic at the time. He replaced the egr as well as the o2 sensor. He then said it was still throwing the same codes and replaced the pcm. Everything worked for about...
  11. JK Tech Forum
    2007 JK with LS1 Gen3 6.0 1) Connected 2-wire Temp Sensor from 6.0 to C102 JEEP connector (Pin#18 ECT) on a "Warmed Up" 6.0 engine. 2) KeyOnEngineOff: Temp Gauge reads "MidRange" correctly in Instrument Cluster. 3) KeyOffEngineOff followed by KeyOnEngineOff: Temp Gauge reads "Cold"? 4)...
  12. TJ Tech Forum
    Good evening WF, I wanted to throw out my situation with an idle issue and associated P0505 code (IAC valve and/or circuitry). I've been chasing this issue for 6 weeks now, largely with the help of this forum and the gurus (Jerry - :worthy:). At this point I'm near to calling the PCM...
  13. JK Tech Forum
    First started with my battery light went on, then a few minutes later all the control lights went on, then it did and cannot restart. Added a new Alternator, belt, and checked the battery. How do I know if its my PCM because it looks costly to take to the dealer.
    pcm
  14. TJ Tech Forum
    Hey friends, got a stumper here that several mechanics have refused to chase... Either at a stop light, starting forward on green, or for example: traveling down a highway offramp with go-ahead signal where I have to downshift and RPM drops low; the car stalls and sputters and sometimes dies...
  15. TJ Tech Forum
    Hey everyone, I am new to this forum, but thought I would try asking for advice. Today I went for a short drive to Walmart. Car started right up, but on the highway threw a check engine light. When I pulled into the parking lot, I viewed the codes and got the following: P2074 - vac leak...
  16. TJ Tech Forum
    I've recently been having an issue with the battery voltage on my Jeep Wrangler 2004 TJ Unlimited. The car would start with 12v visible on the dash gauge, and the "check gauges" light would come on. After replacing the alternator, testing it, testing the battery, and charging the battery back...
  17. TJ Tech Forum
    My '05 TJ drops into limp mode by locking into 2nd gear with a obd code of P0755 2-4 gear clutch solenoid circuit. Sometimes after it sits for a while, all will work fine, but after a bit, right back to limp mode. I have cleared the codes, but it re-throws the code within 10 miles, and limps...
  18. TJ Tech Forum
    I have a 2006 TJ 4.0L 5 speed. While driving, it quit - no sputtering, no indication of a problem, just straight quit. Upon trying to restart, it will crank readily and after a few moments of cranking, it will start to sputter like it is trying to catch, but is not getting enough fuel. The...
1-18 of 57 Results
Top