Jeep Wrangler Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-16 of 17 Results
  1. JK Technical Discussion
    Yesterday I was replacing a faulty crankshaft position sensor and while doing it, the screw got broken and is inside the housing. I know there's a way to get it out using a left-hand drill but there's almost no space there. I've been thinking about gluing the bolt just so I can take the jeep to...
  2. JK Technical Discussion
    Had my Universal Joints replaced at the mechanic shop with brand new original Mopar parts on My Wrangler Unlimited 2011, now the ABS and Traction Control lights are coming on and off ( intermittent - On for a while and then off again ) in the dashboard... Seems like the sensors are not...
  3. YJ Technical Discussion
    87 JY, 4.2 CARB AUTO Trying to bring this old banger YJ back to life. Replacing wiring/sensors/etc. Noticed on the driver side under carb area - two plugs/wiring not attached. One in the intake manifold. What in the exhaust. What the heck are they? Are they needed or can I just eliminate...
  4. Classifieds Archive
    Due to two separate errors on the part of an online seller, I now have two sets of OEM Schrader tire pressure sensors for sale. These are the brand new, never installed 433MHz sensors that fit 2013 through 2017 Jeep Wranglers...Jeep part number 68241067AB. I actually have 10 sensors total...
  5. TJ Technical Discussion
    Long time reader, first time writer.:) Have an '06 Sport 4.0 manual that I made some improvements on about 5 years ago. 4" lift, 4:56 gears and 35" tires. Has about 194k miles. In the last month or so it has started dying without warning while driving. The first time, it started right back...
  6. JK Technical Discussion
    I have a 2015 Rubicon Unlimited which I purchased aftermarket wheels and tires for which the installer said he used 433mhz tpms sensors. However, my TPMS light comes up when I start the vehicle and blinks for a little then goes solid. The PSI is displayed and works but there is clearly an issue...
  7. TJ Technical Discussion
    Hello fellow Wrangler-maniacs, This is my first post, so please forgive me if this post should be in a different forum & my noobness. I have a manual 98 Jeep Wrangler 4.0 I6 with low mileage (91K). About two weeks ago I've noticed that my engine is stuttering during acceleration. It doesn't...
  8. JK Technical Discussion
    I am an American living in South Africa, and getting my 2013 Jeep Wrangler Sahara serviced means at least an overnight stay to get to the nearest dealership. So any help is appreciated. The issue is the auto stability control light comes on and stays on, affecting the auto transmission and...
  9. YJ Technical Discussion
    This is not my first Jeep but it is my first YJ. Never had issue with any Jeeps until this turd came along. I have a 92 YJ with 192,XXX miles on body and 2k on new remaned motor. Clean 99% rust free Florida Jeep. Also a 5 speed. Problem is I ran codes with the turning of the key (three times)...
  10. TJ Technical Discussion
    Basic Jeep History: Year: 1998 Engine: 4.0L 6 Cylinder Transmission: 3 Speed auto Mileage: 83,000 with A/C Tj Sport (Just cause everyone asks these) My jeep is throwing a few codes... P0113, P0123, P0304, and P0306. P0304 and P0306 are generic misfire codes, P0306 came a week or two before...
  11. TJ Technical Discussion
    I have an 02 TJ with 4.0L engine. Runs flawlessly, when it runs. It will randomly just stop running. No stutter, no bogging, no degradation of power, nothing. Just stops. Cranks right back up immediately when I turn the ignition and goes right along. Until the next time. :banghead: I had...
  12. TJ Technical Discussion
    I've got an intermittent check engine light on my 2003 Rubicon with the 4.0L. It says a specific O2 sensor, but with 90k miles I'd like to replace them all. How many do I have? Anyone have the quantity and part numbers for each, especially Bosch? Amy recommendations for a particular brand...
  13. California Jeep Forum
    I recently purchased a 2000 Jeep Wrangler. Recently I took it to the mechanic because it cut off and wouldn't restart. He replaced the crank sensor and for a few days it seemed to be running fine. Then a few days later it began to idle and cut off at every stop light. My mechanic could not...
  14. TJ General Discussion
    well today i was washing my engine and i found 2.... well i dont know how to call this things. i think they are sensors of some kind but i dont know where they go i dont have engine codes. engine runs well for a 2.5L when i first got my tj, all the air filter, tube, were missing so the exowner...
  15. TJ General Discussion
    So I've had a few problems with my 1998 wrangler 2.5L... I'm a woman and I don't know much about whats under the hood... My car was only starting some of the time and after realizing it was just getting worse, I took it to get it fixed today. I really don't care what these people charged for...
  16. TJ Technical Discussion
    I have a 2006 unlimited. The MIL has been coming on and staying on steady for days at a time and then magically goes off. I used the on/off process to check for code and got a P1033 message. I looked it up and found it was "Oxygen Sensor Circuit Slow Response, Bank 1, Sensor 1". I need to...
1-16 of 17 Results
Top