Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey all, I need some help with this brain buster. I have an 07 JK 4x4 auto trans, that is not shifting into first or second gear and drive it will go into but if it tries to slide out of drive. Also My dash cluster is not showing 1st or 2nd gear.
I have replaced shift linkage cable bushing under jeep and the one in console is good but I am also unable to pull the shift linkage cable to go into 1st and second gear. (from sitting in jeep bypassing the gear shift and just pulling cable itself). Could it be an electronic shift lock or has the shift cable itself gone bad?
It all started when my girlfriend drove the jeep and could not get it out of park one day and has just seemed to escalate from there.

Any help would be greatly appreciated!
 

·
Registered
Joined
·
34 Posts
Something similar happened in an 07 Charger we had. One day it just decided it didn't want to come out of park anymore. Turned out that it was a little plastic piece in the actual shifter housing that broke and wouldn't disengage when the brake was pressed. I'd pull apart the actual shifter housing and make sure nothing is broken in there.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks yea there was a plastic piece broken, so I picked up a new/used shifter from salvage yard and gonna install today.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Fixed

Got the shifter installed and it has fixed the problem. Has to play with the ignition cable a bit to get it back just right for all the gears to work properly since I tinkered with it at the beginning. Sometimes key gets stuck and I have to push shifter forward a bit to release it but I will try and adjust the ignition cable a tiny bit to see if that fixes it completely.
 
1 - 5 of 5 Posts
Top