Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 48 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
My very new (bought on Saturday) 10th Anniversary Rubi threw a CEL for cylinder 2 misfire last night and another for cylinder 3 tonight. Running rough, ticking bad, low power. All of this developed between 75 miles and 125 miles on the odometer. Amazed it happened so fast - I was only on my second drive in it. Taking it to the dealer on Wednesday, wish me luck :nonono:
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #4 ·
so did I. Trying to keep my spirits up after spending $50K on a car that is going to get a major engine repair before it has 200 miles on it.
 

·
Registered
Joined
·
3,313 Posts
Doesn't sound like a head problem because your misfire came on the left and right bank at pretty much the same time. There's a good chance that this is a simple fix.
 

·
Registered
Joined
·
1,738 Posts
At least you'll get it over with quickly. Consider yourself lucky that you've got a misfire so soon and can now get the head replaced and never have to worry about symptoms of the defective head. Mine is at 8k, still no CEL and I get 13mpg on a good day.
 

·
Registered
Joined
·
3,313 Posts
At least you'll get it over with quickly. Consider yourself lucky that you've got a misfire so soon and can now get the head replaced and never have to worry about symptoms of the defective head. Mine is at 8k, still no CEL and I get 13mpg on a good day.
Don't scare him away. He definitely has an AC head and has way way too few miles to exhibit the correct symptoms. This is probably a fuel delivery, spark, or computer issue. minor stuff. I'll eat my hat if they give him two new heads.
 

·
Registered
Joined
·
2,321 Posts
50k :eek:
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #10 ·
Roadside assistance tow truck is on its way to my house and the dealer is going to squeeze it in to the shop today. I should know what is wrong later today.
 

·
Registered
Joined
·
344 Posts
Well that just sucks! You should demand they show,you the old head and make sure it's an AC or higher. If they are still using AA heads that would be a shame!
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #16 ·
It is my intention to get the numbers on the heads and the number on the engine tomorrow. Thanks!
 

·
Premium Member
Joined
·
10,153 Posts
I thought this cylinder head issue was provoked under certain conditions?

Did you check the vitals? Oil pressure, coolant temp on the EVIC?

.
 

·
Registered
Joined
·
3,313 Posts
you should probably ask them why you're getting a code on both cylinder banks? how does replacing one head fix the other code?
 
1 - 20 of 48 Posts
Top