Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just purchased my first jeep ever and when I got it the wipers worked normal. With scope he exception of the windshield clean function but not worried about that at the moment. What is going on is that it seems that the switch on the steering column works fine cause I can hear the motor running when I turn on the wipers. But the wipers don't move. Was driving down interstate yesterday and noticed that they were not working and actually started to flip back in the wrong direction without them on. So it seems there is a linkage problem and I need to get it fixed fast cause there is a snow storm coming. Any suggestions would be greatly appreciated. I know it is mounted in windshield assembly but any tricks to get them working without having to disassemble the dash and windshield?
 

·
Registered
Joined
·
91 Posts
Fold down the windshield and you will be able to see how everything works. Its really simple to look at. No need to disassemble anything. Just make sure you lube your hinges so they don't snap. They're a pita to change out.


Hopefully this helps.
 

Attachments

·
Registered
Joined
·
514 Posts
Ya there essentialy the same.. I hit the hinges with wd40 the white grease the pull slow.. stop breathe ask myself what that snapping noise was.. then pull somemore till ya see it.. real simple setup..
 

·
Registered
Joined
·
91 Posts
Im not sure but you could probably use that diagram as a reference from cj5's through the yj's. Not sure about tj's though. Thats the one I used when I switched out my windshield frame. Some of my plastic bits were brittle and i broke them so be careful.
 
1 - 5 of 5 Posts
Top