Jeep Wrangler Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
I was at work, closed, then started up the Jeep. It started up beautifully. Ran for three minutes while warming up then it just died. Will not start back up. It has the Rush ignition, it is nuttered, and its is still carbureted. I did the rush mod many months ago and had no problems, did the nutter last week and no problems at all. I replaced the fuel pump 4 months ago. Oh and when I get out to see if the fuel is actually squirting into the carb...it isnt. Starting fluid makes it start but it obviously shuts down when thats out. And it has gas. Anyone have any ideas?
 

·
Premium Member
Joined
·
691 Posts
Fuel pump? fuel filter? Pull the line off the carb and check for fuel pressure.:thumb:
 

·
Registered
Joined
·
581 Posts
She's not dead, not even remotely.

Simple fuel delivery problem.
 

·
Registered
Joined
·
506 Posts
She's not dead, not even remotely.

Simple fuel delivery problem.
This. First start to see if there's fuel in the tank (it happens more than I'd like to admit)

Then see if there's pressure sucking in, and just work your way back until you find the culprit.

The culprit to my fuel delivery problem was a clogged fuel filter. Clogged with 20 years of disintegrating cheap fuel line that's OEM.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #7
Turned out it was vapor lock. Put in Gas-Dry and its all good! Kinda bummed it wasnt the carter...was stoked to get the avenger carb :action-smiley:
 

·
Registered
Joined
·
553 Posts
WranglerDude92 said:
Turned out it was vapor lock. Put in Gas-Dry and its all good! Kinda bummed it wasnt the carter...was stoked to get the avenger carb :action-smiley:
Then get it! That carter is junk!
 

·
Registered
Joined
·
91 Posts
Discussion Starter #9
It runs good for now. Need to recover from tuition and books now.
 
1 - 9 of 9 Posts
Top