Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
About a month ago I came out to start my Jeep, nothing. Wouldn't turn over wouldn't start, no lights just a click the first try and then the next key turn nothing. Jumped it and got it to start, two pedaled it to an alternator shop. They told me my battery was arcing off the tub. Strapped the battery down, and it ran for a week. Then same problem, jumped it again, disconnected battery with jumper cables on. Decided it was the battery, got a new one. It ran for another week then on the way home it gave me a no bus light and all my gauges went sky high! The next start up they were dead but jeep still started. The following start up was fine no issues except a rough shut off. Now it won't even turn over just a click, no lights except a faint e brake.
 

·
Registered
Joined
·
204 Posts
follow your wires and make sure all posts are clean and tight.

a loose wire on the starter can act like that. or a loose ground wire to body etc.

id follow those main wires and make sure everything is cleaned and tight.
 

·
Registered
Joined
·
166 Posts
Replace battery. Perform parasitic draw test. Question wtf they mean by arc'ing off the tub. Unless it's a quick bump (that will not drain a battery) that thing will start welding things together until it blows.
What a loose battery can do is allow the plates inside to knock around and short each other. Which would be a good reason to go with an Optima style battery.
Still sounds like you have a draw somewhere.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
My battery is brand new and sits at 12.5 connected which makes me think it isn't a parasitic draw. There's a small burn mark under my hood by the battery which is why they said it was arcing. They strapped it down, still didn't start, replaced a battery terminal and it started. Now the same problem as before won't start, no lights, no turn over.
 

·
Registered
Joined
·
281 Posts
hi lacey I would check all of your fuses in the pdc and also check your fusible link if the fusible link is burned out that would cause nothing to work.
 

·
Registered
Joined
·
281 Posts
you can try to jump start it but i don't think it will work if fusible link is bad. I would also check all your grounds and make sure the connections at battery is tight I would also check your ignition switch that would also cause your symptoms.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
I'm saying it's possible to jump start it. That's why I've kind of ruled that out. I'm putting a new alternator in and then I'll check my ignition switch and tumbler.
 

·
Registered
Joined
·
281 Posts
okay i'm sorry my bad I misunderstood what you were saying in your last post. Okay sounds good hopefully by replacing the alternator and ignition switch and tumbler it will be fixed
 
1 - 9 of 9 Posts
Top