Jeep Wrangler Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My original problem was that the blower switch only operated on High speed. I installed a new resistor and repaired it, thanks to some very knowledgable people on this forum. However, when I finished that job the vent selector now is not changing vents for me. I just get airflow out of the defroster. Previously, when changing vents, I would hear a light thumping sound. Like a vent door closing. Any help is appreciated.
 

·
Knows a couple things...
Joined
·
48,836 Posts
HVAC problems like that are often (usually?) caused by a vacuum leak somewhere between the intake manifold and the HVAC system. HVAC doors/flappers are moved by vacuum from the engine.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks for the quick reply Jerry. I gave it a look today but didnt see any problems. Checked the 2 fuses also and they were good. Im no mechanic by any stretch of the imagination, but I'll look again. I'll also have my wife listen for leaks. My hearing isn't what it used t be.....
But it sure is strange that as soon as one issue is fixed, the other one happens. Just wondering if I may have caused it while installing the blower fan resistor.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Well, I found the problem. Me..... lol. I traced out the vaccine line under the hood. No issues there. Then got behind the glove box and saw that a white connection was separated. Connected it up and good to go. It was a vacume manifold connector that I must have knocked apart somehow. I'm learning a little along the way.....
 
1 - 9 of 9 Posts
Top