Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
So I have a 2006 Unilmited, 6 cylinder, 129k miles. My first smog test is due next month and I figure it's time to fix some ongoing issues. I've searched here alot but could use some fresh advice, help, direction.

1. Heater blower fan. Started only working on high only on every setting except high where it was off. Been going on about 8 months. Now it's stopped working unless I find a perfect spot turning it. Resistor or controller?

2. Fuel level sensor. About a year ago the gas gauge would be at half tank then all of a sudden drop to empty, restart it would show the level then drop down fairly quickly to empty. Now it's doing it at 7/8th tank and I ran out of fuel recently because I forgot to check. Obviously it won't pass smog text with this problem since the CEL is on. Checked Rock Auto and the cheapest seems to be around $148. Correct that I need to replace the whole sending unit?

3. Transmission wouldn't shift out of 2nd gear all of a sudden. finally stopped, restarted and it was fine. time for a transmission service and filter change?

4. Same day I had the transmission problem I was in the snow and shifted to 4wd and noticed a vibration from underneath, something I hadn't noticed before. so I took it out of 4wd and it didn't disengage right away and when it did there was a slight clunk when it did. Never had this happen before. No weird vibrations when driving out of 4wd.

I guess I've been putting this stuff off anf it's time to get it all fixed. Thanks!
 

·
Registered
Joined
·
1,365 Posts
1) sounds like the resistor
2) I don't think the fuel sending unit will throw a check engine light but I could be wrong.
3) ?
4) I get the clunk every now n then but the vibration sounds like it could be a u-joint. It's not under load in normal driving so maybe it's not vibrating but once it's under load in 4wheel drive it causes the vibration. Just something to check.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Well it wasn't the resistor, changed it today. As much as that was a pain I'll keep the new one in.

I guess I need to make a list and looks at expenses now.
 
1 - 3 of 3 Posts
Top