Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 39 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I have an 07 JK that I’ve had since 2008. It doesn’t get driven too often (<20k miles). This weekend it drove it about 15 miles, and turned it off for about 20 minutes. When I went to start it, it would run for about a second and then shut off. This repeated for about 5 or 6 times, and then when I turned the key it wouldn’t even crank. I let it sit for about 5 minutes and then it cranked up and started and ran fine for the ride home. The same thing happened to me about six months ago, but in my garage when I started it cold. A long shot, but I’m hoping someone here has experienced this before and can point me in the right direction.
 

·
Registered
Joined
·
171 Posts
My daughter’s 08 also had intermittent starting problems. I thought it was the starter but then read that adding grounds from the battery to the engine and to the body can help. I did this and it’s been fine so far.

Yours stopping after a minute sounds different though. Sorry, not sure what that might be.
 

·
Registered
Joined
·
6,738 Posts
Check for codes. With a Jeep that age adding an extra 4 gauge ground wire never hurts.


Sent from my iPhone using Tapatalk
 

·
Retired Moderator
Joined
·
100,607 Posts
:welcome: to the Forum..:wavey:
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #6 ·
I can certainly add the ground. And I'll check for codes. One other thing...ever since I had the Jeep, it seems that the ignition would stick. When I turn the key to crank, and then release it, it would continue to crank for a fraction of a second. Maybe there is a relay or module or something that is going bad?
 

·
Registered
Joined
·
108 Posts
Are you running any accessories? The nut that tightens the negative terminal needs to be seated properly. There is a bolt that uses a 6mm nut directly behind the terminal, thats where you should attach any accessory. Clean and tighten the terminals and see if that works.
 

·
Registered
Joined
·
6,738 Posts
I can certainly add the ground. And I'll check for codes. One other thing...ever since I had the Jeep, it seems that the ignition would stick. When I turn the key to crank, and then release it, it would continue to crank for a fraction of a second. Maybe there is a relay or module or something that is going bad?


That’s normal. It’s called tip start. You can turn the key until starter engages then let go. Starter will continue the turn until engine starts.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,738 Posts
Are you running any accessories? The nut that tightens the negative terminal needs to be seated properly. There is a bolt that uses a 6mm nut directly behind the terminal, thats where you should attach any accessory. Clean and tighten the terminals and see if that works.


The older 2007-11 3.8 Jeeps have one big clamp rather then multiple bolts like the 12-18 3.6 clamp.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #11 ·
I haven't added any electrical accessories, other than swap out the factory radio for a Pioneer unit. That was a couple of years ago.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #12 ·
Ok, had another occurrence of my starting issue. Went to the gas station and when I started it after filling up, it ran for a second and shut off. I plugged in the OBDII adapter and had no codes showing. Tried starting it a few more times and it kept shutting off after about a second. Then I would turn the key and nothing other than the lights illuminating on my dash. No crank, no click, nothing. I let it sit for a few minutes and still would not crank at all. Finally decided I was going to push it from the pump to a parking spot, so I put it in neutral. I gave it one more try at that point and it started right up and ran fine all the way home. Started fine at home too, even in park. So it might be associated with the "Park" position switch or sensor? Not sure why that would cut it off after a second though when it did start. Does this additional information give anyone an idea of what might be happening?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #13 ·
Ok, I’ll keep updating this thread with more info as I get it. Hopefully something I find will give a clue as to what my problem is. I mentioned before that I was not getting any error codes. Well, that was with Dashcommander app. I just got JScan and although the normal scan doesn’t show any codes, the advanced scan gives me 3 codes: U0184 (lost communication with radio), P0688 (ASD circuit issues), and P0513 (incorrect immobilizer key invalid skim key). I imagine the U0184 is simply due to an aftermarket radio. The ASD code certainly sounds like it is relevant, but I’m not sure about the key one. None of the codes will clear. Any suggestions?
 

·
Registered
Joined
·
2,105 Posts
IMO there is an issue with the SKIM module. It picks up the chip in the key and then lets the start. Are you having intermittent TPMS issues, like low pressure warnings? The SKIM receiver is used by both.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #16 ·
Now low pressure warnings, but that is because the TPMS doesn’t work. To be honest, I’m not even sure it has a TPMS system. Was it standard in 2007?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #17 ·
IMO there is an issue with the SKIM module. It picks up the chip in the key and then lets the start. Are you having intermittent TPMS issues, like low pressure warnings? The SKIM receiver is used by both.
Thanks terpsmandan, I think you are on to something! I've been reading up on the "skim" system. This morning the jeep wouldn't start. I tried the spare key with a new battery in the FOB, but same issue, so that rules out the key. I tried to start it 5 times. Each time it ran for a second or two and then shut off. On the 6th try it wouldn't crank. This sounds like the anti-theft function.


So it might just be the skim module as you suggested. Is this the same thing as the WCM?
 
1 - 20 of 39 Posts
Top