Jeep Wrangler Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I searched this forum and found several P0304 code problems but all dealing with the Pentastar 3.6L engne. My JK is a 2011 with the 3.8L. My engine light is not blinking just steady on. There is no noticeable performance issues. I cleared the code but after a couple of trips it came back on. Today I changed the spark plugs hoping this might be the cause. Somewhere I red that the fault code/engine light will clear itself after a predetermined number of drive cycles after problem is fixed. Can anyone confirm this information?
 

·
Registered
Joined
·
2,086 Posts
I had a similar issue recently. I had some issues with pinging on load and replaced the plugs and wires at around 110k. It stopped the pinging and I was able to lower the octane I was running to 89. More recently I had a misfire,reduced power, and a CEL. Also heard an occasional click when running. I opened the hood with the engine running and saw the reason for the click. The coil was arcing from the one and three terminals to the mounting bolt. I covered the bolt with electrical tape as a temp fix and coil and wires replaced. Fixed that problem but then pulled a P0420. Had it scanned and the O2 sensors were working properly but enough fuel went down the pass side exhaust to ruin the cats. Got those replaced and now all is well at 175k
 

·
Registered
Joined
·
879 Posts
I had a misfire on my 3.8l due to a bad plug. You are correct in your assumption that the code will clear itself after so many ignition cycles without errors.
 
1 - 3 of 3 Posts
Top