Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 130 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
so my gf's 2012's windshield wipers have been going off when you use the turn signals, which is weird because the stalks are on either side of the wheel.

turn on the signal, wipers make one pass.

i didn't believe her until today when i was driving and it did it to me everytime i used the signals.

if that isn't bad enough, they now started going off without having touched anything, just driving down the road and they make a few passes.

anyone else have this issue?
 

·
Registered
Joined
·
656 Posts
get the battery checked...
don't asked, but what I have read here many weird electrical problems are due to a bad battery.
 

·
Registered
Joined
·
29 Posts
Either its haunted or you need to take it to the dealer. Odd cross connections can be dangerous. Then so can being haunted:rofl:
 

·
Registered
Joined
·
278 Posts
I know this sounds like I'm being a smart ass but was it raining or sprinkling? The reason I ask is my last car had automatic sensors on the windshield so when it felt water the wipers went on. Does Jeep have this option?
 

·
Registered
Joined
·
8,968 Posts
I know this sounds like I'm being a smart ass but was it raining or sprinkling? The reason I ask is my last car had automatic sensors on the windshield so when it felt water the wipers went on. Does Jeep have this option?
Not on a JK.
 

·
Registered
Joined
·
2 Posts
Actually I'm in a desert and it hasn't rained in the last 10 months! It's a peculair thing and the wipers generally go on when I turn the indicators on.
 

·
First Jeep: M38A1
Joined
·
368 Posts
Sounds like some sort of intermittent short. It should be throwing codes that your dealer can check out, and then replace something(s). If no codes, and the problem won't replicate in Park, then insist on a test drive by the Service Manager.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #12 ·
haven't gotten a solution yet because we haven't taken it in. we'll get around to it sooner or later, but as of now it's not a major failure or issue... it's almost humorous.

was just curious if anyone else was getting the same thing.
 

·
Registered
Joined
·
771 Posts
Read all over, a lot of steering wheel/column issues are solved by hitting the horn. Depress the horn hard for a few seconds. Worth a noisy shot IMO.
 

·
Registered
Joined
·
5 Posts
I'm sitting at the dealer right now hopeing they get it fixed bc we just got back from a trip and it was so annoying! I'll let you know what they come up with.
 

·
Registered
Joined
·
5 Posts
After waiting for two and a half hours. They told me they wouldn't know what it was unless it did it in the shop :-(. Please let me know if any of you get yours fixed bc it's driving me crazy
 

·
Registered
Joined
·
579 Posts
Terradb82 said:
After waiting for two and a half hours. They told me they wouldn't know what it was unless it did it in the shop :-(. Please let me know if any of you get yours fixed bc it's driving me crazy
Just had the wife's JKU in for this exact issue last week. They said they were able to reproduce it while there and replaced the integrated control module (I think that is what they called it). Appears to have fixed it as it hasn't happened since she got it back on Friday.
 

·
Registered
Joined
·
149 Posts
I had a wiper mishap as well. A little different than what was stated.

I was cleaning the Jeep and my wife's Maxima and had the radio playing from the Jeep. After a good 30 mins I went back into the driver seat to start the Jeep and move it. Turned the key, engine turned over and my wipers started going. Check the stalk and they were off. They kept going no matter what I did.

I turned the Jeep on and off about 3 times. I finally realized that I had no dashboard lights or instrument cluster displays. After a few choice words I went to the engine bay and wiped down some dripped water on the fuse box cover and went and depressed every fuse. Make sure nothing was loose.

Went back to driver seat, turned the key and got more of the same. I was furious at this point b/c it was Sunday and this would piss me off all day now. Out of frustration I just started trying things. I turned the lights on from theleft stalk and all of a sudden my dashboard cluster came on and my wipers stopped.

Hasn't happened since and hoping it doesn't anytime soon.
 

·
Registered
Joined
·
6 Posts
I have the same problem and will be bringing my 2012 Rubicon in next week. This morning I started the jeep and didn't touch any switches and the wipers turn on and made three passes, turn off and back on again for two more passes. I had a problem with my 2007 Jeep Liberty but wasn't the wipers. When I turned the blinker on, left or right, when I completed the turn and the blinker turned off, the headlights would flash off and on. This really bothered people coming the opposite direction, they thought I was flashing them for some reason.
 

·
Registered
Joined
·
2,976 Posts
Must be the season for this crap. I turned on my 2010 the other day and the wipers and headlights wouldn't turn off, and the turn signal wouldn't work. Someone suggested disconnecting the battery for a bit, and that worked. Good thing because I'm waiting right now to have it inspected...I didn't have a few hundred dollars for it to be fixed and have my tags die in the process!
 

·
Premium Member
Joined
·
1,298 Posts
My 2012 has been doing the same thing. Every once in awhile they make one pass. Had it in to the dealer last week. Said they never heard of that. They flashed the computer. Drove off the lot and they made one swipe. So much for flashing the computer :rofl:
 
1 - 20 of 130 Posts
Top