Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter #1
I just purchased this about 3 weeks ago, and sometimes air will blow out the main cab vents but most of the time its just the defrost vents at the window?

no matter what i dial , .. on the far right control, it only blows air out the defrost vent at the window? then suddenly it started working one morning, .. about 5 days ago it stopped again, so i went to a dealer, and they wanted me to leave the car over night, said it would take some time to look into it....

so this morning when i started up the air was blowing out the cab vents .. again. omg. so frustrating?

i have AC and if i turn the ac on, cold air blows out the top vent, if i move the middle knob to heat, it blows hot air.

seems to just be the far right knob that controls where.. the air blows .. anyone know something I can look at, to see why this works some times and then stops...?

new jeep owner looking for some assistance. thanks in advance...

:banghead:
 

·
Registered
Joined
·
1,419 Posts
dealer gotta fix that...That is not normal
 

·
Registered
Joined
·
300 Posts
Discussion Starter #3
dealer gotta fix that...That is not normal
Ya, i figured. i did some searching on the forms, some ppl had said on older models a tube could come detatched and cause it to only blow air out of the defrost/window. part only and they used a twist-tie to fix .. i just rather do it my self vs driving all the way to the dealer. .. everything else about my new jeep wrangler JK is super . i love the power, handleing etc..
 

·
Registered
Joined
·
300 Posts
Discussion Starter #4
update:

dealer fixed it. there is a connection device that electronicly controls where the air flows, if its not pluged in, it defaults to the vent at the windsheild. it had come lose and they just reconnected/secured it. and i was good to go.
 

·
Registered
Joined
·
1,419 Posts
update:

dealer fixed it. there is a connection device that electronicly controls where the air flows, if its not pluged in, it defaults to the vent at the windsheild. it had come lose and they just reconnected/secured it. and i was good to go.
Sweet! :thumb:
 
1 - 5 of 5 Posts
Top