Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Need help if anyone has had this problem. Turned on the heat in my 13 JK last night and nothing but cool air. Checked the thermostat good, lines under the hood to heater core hot, line under dash inside hot. Been getting flashing liguts on control know periodically. Anyone else run into this?
 

·
Registered
Joined
·
8,968 Posts
Sounds like there's a problem with the blend doors not opening/closing. If you're still under 3/36 bring it in under warranty.
 

·
Registered
Joined
·
1,216 Posts
Been known problems with sludge from the coolant plugging the heater cores in some JKs. I had sludge in my reservoir and had to have my heater core, radiator replaced. They tore out the entire dash.
 

·
Registered
Joined
·
8,968 Posts
Been known problems with sludge from the coolant plugging the heater cores in some JKs. I had sludge in my reservoir and had to have my heater core, radiator replaced. They tore out the entire dash.
This is a known issue. The light flashing in the A/C heater control module indicates an electrical malfunction.
 

·
Registered
Joined
·
5 Posts
Been known problems with sludge from the coolant plugging the heater cores in some JKs. I had sludge in my reservoir and had to have my heater core, radiator replaced. They tore out the entire dash.
Has anybody had any luck getting this covered outside of factory warranty? It looks like Im having the same issue and am at 48k on mine...
 
1 - 7 of 7 Posts
Top