Jeep Wrangler Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter · #1 ·
I have a 4 day old JKUR and have a question about the cruise, you have to turn it on everytime you start the Jeep, but also once you turn it on and then Set it there is no indication that you are using the cruise. my honda has an indicator to say cruise is on and then a second indicator that tells me the cruise is Engaged.

i just want to make sure this is normal behavior.....
 

·
Registered
Joined
·
119 Posts
normal
 

·
Registered
Joined
·
1,505 Posts
From the 2013 owners manual...
To Activate​
Push the ON/OFF button. The Cruise Indicator Light in
the instrument cluster will illuminate. To turn the system
off, push the ON/OFF button a second time. The Cruise​
Indicator Light will turn off.

My JKUR has not been delivered yet, so I can only point to the owners manual.
 

·
Registered
Joined
·
530 Posts
yeah. That.

There should be a little cruise light on the guage cluster. If yours doesnt show it then look for it when you turn on the key and make sure it's not burned out.

-Cheers!
 

·
Registered
Joined
·
899 Posts
I too have had Honda's in the past. What you are seeing in the Wrangler is correct. You have to turn it on every time you start the Jeep and there is no indicator when it is engaged other than the speed remains constant when you take your foot off the gas.
 

·
Registered
Joined
·
1,505 Posts
Picked up my '13 JKUR today... as soon as I touch the crusie on/off button, a lamp comes on that says "CRUISE". Driving it, there is no other indicator when the cruse is actually in control.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top