Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Has anybody had a issue with a dead battery? I replaced my battery and it went dead again, I then took it to the dealer and they told me they cleared a bunch of codes? well the dam thing is dead again! brand new battery. When I asked dealer,s mechanic if he saw a draw on the battery he told me he saw a
7 volt draw with no amps? does anybody have any clues to what is going on?

please help!!
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #2 ·
Has anybody had a issue with a dead battery? I replaced my battery and it went dead again, I then took it to the dealer and they told me they cleared a bunch of codes? well the dam thing is dead again! brand new battery. When I asked dealer,s mechanic if he saw a draw on the battery he told me he saw a
7 volt draw with no amps? does anybody have any clues to what is going on?

please help!! oh ya he also told me the 7 volt draw with no amps is normal?
the guy has got to be full of it, what is making it go dead?
 

·
Registered
Joined
·
8,968 Posts
Did they indicate what the codes were that the tech cleared? That's important. There has to be some type of parasitic draw. It can come from a number of electronics that could be malfunctioning or from some type of an aftermarket set up if you have one. It has to be tracked down/troubleshooted. That's the only way to find out.
 

·
Registered
Joined
·
31 Posts
How fast does the battery go dead? You park it after work at 6pm and its dead by 6am the next day? or you only drive it every few weeks for trails only or something? a 7 volt draw with no amps is a really low draw and shouldn't cause it to go dead very fast.

What have you altered on the Jeep since buying it, electronics wise?
 
1 - 4 of 4 Posts
Top