Jeep Wrangler Forum banner

1 - 7 of 7 Posts

Premium Member
Joined
3 Posts
Discussion Starter #1
My wife hit a speed bump with our 2015 Jeep JK and it died. Engine will crank when starter engaged but no ignition. Checked all the fuses and none blown. Pulled spark plug and engaged starter, no spark. Fuel pump kicking in when key turned. No codes set.
Any ideas?
 

Registered
Joined
82 Posts
My wife hit a speed bump with our 2015 Jeep JK and it died. Engine will crank when starter engaged but no ignition. Checked all the fuses and none blown. Pulled spark plug and engaged starter, no spark. Fuel pump kicking in when key turned. No codes set.
Any ideas?
馃Just a guess here but could it be the engine immobilizer? Maybe a wire popped off from the SKIM or ??? Which might explain why everything works but no spark?
馃馃馃
 

Premium Member
Joined
508 Posts
Could be a bunch of different things. Cam sensor, crank sensor just to name a few. Really need to diagnose this. Plugging a good scanner in and pulling codes and looking at some of the live data would be a start.

Per the previous poster. You don鈥檛 have a red light on the dash that comes on? That would be the security light. I think if it鈥檚 security key issue the Jeep will start but die in 2-3 seconds.
 

Premium Member
Joined
3 Posts
Discussion Starter #5
Thanks for the info, correct no red light. Tried disconnecting battery for 30 minutes and pulling plugs off ECU still no help. Hopefully just a sensor and not the ECU.
 

Registered
Joined
2,092 Posts
is your jeep a rubicon? I have seen posts here where the wire harness to the swaybar disconnect shorts and causes a no start issue
 
1 - 7 of 7 Posts
Top