Jeep Wrangler Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I purchased my 2015 JK new. I am just starting to have this issue with the shifting lately. After driveng for an hour in highway speed,the rpm goes up to almost 3000 while going 100 km/h. I brought the jeep to the dealership but they cannot replicate the problem. however, they said they had to upgrade the TCM, trans control module. It is still doing it. Found a way to deal with it by setting my Cruise Control, this way when I press set or resume RPM goes down to 2100 at 110 km/h speed which I think is normal RPM? Now my cruise control stopped working. i would love to hear from you guys, I am running out of time, I only have 5000 km more before my warranty expires.
 

·
Administrator
Joined
·
12,448 Posts
@JeepCares

Sounds like you many need to leave it at the dealer for a few days to see if they can replicate the issue. What was the reason they had to upgrade the control unit? I tagged jeepcares above as they handle dealer concerns or can try to help with them.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thank you so much. I meant software update. I brought it back to the same dealership today. I gave permission for the tech to drive it until they could replicate the situation. I am hoping to hear from them tomorrow. Posted another thread of the same content, I thought my first one did not go through.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Yes, every time you're on the highway doing 110 km/h or over and have been driving for at least 45 minutes. Does it have to do with the temperature?
 
1 - 6 of 6 Posts
Top