Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I went canoeing yesterday. Put the Jeep in 4h to get down by the boat launch because it was very muddy. No Problem. After loading the canoe onto the Jeep, I Pulled out of the boat launch onto the road, and switched back to 2h... The light went off, but It didn't seem to switch over. It was VERY sluggish, and I heard a noise, almost a grinding noise... I'm not sure how to describe it. I continued down the road driving on the soft shoulder, trying to switch. After about a mile, I heard a LOUD bang.. and the Jeep was good to go... back in 2wd... My question is... Did I screw something up? Do I dare use the 4wd again?

1990... 2.5l... 193,356 miles.....
 

·
I got nothin'
Joined
·
1,901 Posts
You probably had more traction than you thought on that boat ramp... What you are describing sounds very much like the driveline binding up from not being able to turn the front and rear tires at different speeds. The loud bang was most likely your transfer case disengaging while under load. Next time it feels that way, stop and back up 20-30 feet and it should disengage without any issues.
 

·
I got nothin'
Joined
·
1,901 Posts
Probably not, but I would look underneath to see. And next time you are on a dirt road, put it in 4wd to see if you get any grinding from the t-case. I would be VERY surprised if you actually did any damage to your Jeep...
 
1 - 4 of 4 Posts
Top