Jeep Wrangler Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I'm trying to wire up the harness for install. The Maestro came with a harness that has a TON of wires on it, I can't figure out which of these need to be wired to the CH1. I am assuming red is power and goes to red on the CH1 and the black/grey stripe is ground and goes to black, is that right? Anything else need to be wired?


Joe
 

·
Premium Member
Joined
·
698 Posts
I'm trying to wire up the harness for install. The Maestro came with a harness that has a TON of wires on it, I can't figure out which of these need to be wired to the CH1. I am assuming red is power and goes to red on the CH1 and the black/grey stripe is ground and goes to black, is that right? Anything else need to be wired?


Joe
I'm not sure about your radio, but I just installed a Kenwood bells and whistles and a Maestro in my Jeep. The maestro came prewired with some other T-harness and the Maestro wires that were not needed were still in the box. So, as long as you wire from the radio to the Maestro using the same color connections you should be good. At first I wired the "spare" power wire that came with the Maestro into the Maestro. Duh. I needed to connect the power wire from the radio to the Maestro. You will have wires left over.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I'm not sure about your radio, but I just installed a Kenwood bells and whistles and a Maestro in my Jeep. The maestro came prewired with some other T-harness and the Maestro wires that were not needed were still in the box. So, as long as you wire from the radio to the Maestro using the same color connections you should be good. At first I wired the "spare" power wire that came with the Maestro into the Maestro. Duh. I needed to connect the power wire from the radio to the Maestro. You will have wires left over.

The harness the Maestro came with has a harness in it with a ton of wires plus 2 that were extra long. One black one with a white/gray stripe and a red one, and a TON of other wires. I figured what ton would left over and wired the black and red the red on the harness that will hook up to the radio. Sounds about right, right?
 

·
Premium Member
Joined
·
698 Posts
My power wire was red, yellow, black if I recall. Plug it between the radio and the maestro.
Did you program the maestro with your computer?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I have that one too. Are you saying I don't need the harness with the billion wires at all? This one here.

Well, I broke down and called the support line. I was expecting to get somebody reading a script in Bengaluru or Manila, but i guess Canada hasn't caught on to that whole off-shoring thing. The girl was quite helpful, and turns out I don't know any of the harnesses that came with the unit.



Thanks,
Joe
 

·
Premium Member
Joined
·
698 Posts
*need and of the harnesses
yes, that's what I was saying that you will have a bunch of wires left over once you connect the maestro to the radio. Some of the other wires match up colorwise, but if they don't connect the maestro with the radio, then they are useless.
 
1 - 8 of 8 Posts
Top