Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I did some wheeling in 4 low and high and now my 4WD indicator light is stuck on my dashboard. I know the 4WD is disengaged, but I can't get the light to turn off. Any suggestions are appreciated.
 

·
Registered
Joined
·
185 Posts
Did you fix it yet?

Just make 100% sure you are out of 4x4, you're supposed to shift in and out of 4x4 while the rig is still moving or it could get stuck in gear. After that if it is still on have the dealership check it out.

I've used my 4x4 fairly often and only had this happen the first time I used it because I forgot to shift while moving.
 

·
Registered
Joined
·
1,527 Posts
It sounds like you have a vacume leak, mine did the same thing. I found the main vacume line from the manifold to the CAD system broken, very simple fix and no need for a dealer.
 

·
Registered
Joined
·
185 Posts
I stand corrected, I'm still under warranty so I let them deal with anything wrong currently...
 

·
Registered
Joined
·
1,527 Posts
Hey no problem, if his were under warranty I would have suggested that but his is an '04.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
The vacuum lines look good. The Indicator light goes off when I'm in 4wd and stays off when I pull it up to neutral. In 4 low the indicator light come back on, but doesn't indicate low lock. The rear axel lock light comes on with no problems.

I can feel the 4wd engage and disengage in both 4 hi and low. Could it be electrical?
 
1 - 7 of 7 Posts
Top