Jeep Wrangler Forum banner
921 - 934 of 934 Posts

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #922 ·
Hey Ted! For one, the battery is dead. Lol!

But I have a condition where if I cranked cold, it would run for maybe a w seconds then die. If I repeated this process and tried to start it again, it would fire on 3 or 4 cylinders, then kill. I'm unsure if it's related to the o2 sensors just reading regular air and it dumping fuel or what. I plan on getting the exhaust hooked up, and if that doesn't solve it, I'll do some more researching.

I have a feeling the exhaust won't solve it though as I've seen engines run on stands before.

It would literally fire on a few cylinders then die. Then if I continued to crank it, it would fire on a cylinder every so often like it wanted to start, but just couldn't get enough cylinders firing.
 

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #923 ·
There was a MAF code before, I cleaned it, then reinstalled it and clears the code. It could be possible that the code returned and it's just faulty.

Just something for me to look into.
 

·
Registered
Joined
·
483 Posts
Hey Ted! For one, the battery is dead. Lol!

But I have a condition where if I cranked cold, it would run for maybe a w seconds then die. If I repeated this process and tried to start it again, it would fire on 3 or 4 cylinders, then kill. I'm unsure if it's related to the o2 sensors just reading regular air and it dumping fuel or what. I plan on getting the exhaust hooked up, and if that doesn't solve it, I'll do some more researching.

I have a feeling the exhaust won't solve it though as I've seen engines run on stands before.

It would literally fire on a few cylinders then die. Then if I continued to crank it, it would fire on a cylinder every so often like it wanted to start, but just couldn't get enough cylinders firing.
Man, that could be any number of things.

Bad tune, maybe? Can you have whoever flashed your ECM to look at it again?

Bad/clogged fuel injectors?

Bad MAF or throttle body might cause it run rough.

That really stinks Jon. I hope you get it going soon. I know that's frustrating.
 

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #925 ·
I shipped it to the guy on LT1 swap and he flashed it, so it wouldn't be easy to get it back to him.

I replaced all fuel injectors with new ones from online.

I planned on trailering it to a tuning shop to see if they could further diagnose it if I can't make any headway.

The problem has really kept me from working on it just because I didn't want to tackle it. Lol!
 

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #927 ·
Man, that could be any number of things.

Bad tune, maybe? Can you have whoever flashed your ECM to look at it again?

Bad/clogged fuel injectors?

Bad MAF or throttle body might cause it run rough.

That really stinks Jon. I hope you get it going soon. I know that's frustrating.
I keep trying to quote your posts, but I couldn't figure out what I was doing wrong. Lol got it!
 

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #928 ·
Not sure if I mentioned, but the Jeep is at my father in laws house because my house was expected to flood and I don't have the Jeep insured.

Anyways, I just ran over there and picked up the battery to see if it will hold a charge.

Here's a picture of it. It's got a little bit of a rake. 2 inches from wheel to wheel measured from the frame to the ground. Once I get some miles on it and a spare tire on it I will see how much adjusting I need to do to get it back to about 1 inch. Tire Motor vehicle Wheel Automotive tire Automotive design
 

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #929 ·

Here's a video that can explain how the 02 sensors can cause a no start condition after a good start. So, like I said previously, I'll get this thing trailered to the exhaust shop and work from there.
 

·
Registered
Joined
·
2,398 Posts
Discussion Starter · #933 ·
See. I was tempted to buy this... But instead with the money I'd be spending there, I'll just fix the jeep. Lol
Wheel Tire Car Vehicle Land vehicle


Even though I love that color. Lol as you guys can see, I'm excited to be back.
 

·
Registered
Joined
·
1 Posts
New member just got a 2004 Tj 5 speed manual, researching LS swap, plan on keeping it manual does that mean for the drive train I only need one Novac adapter to mount the to my existing bell housing.
 
921 - 934 of 934 Posts
Top