Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter · #1 ·
Hey, I just installed some Pioneer TS-G1645R speakers in my mom's 15 JKU to get some clearer sound, but when I tried the new speaker out any bass whatsoever has an awful distorted sound coming from it. It honestly sounds like a fart almost. I left the stock speaker in the other side and it sounded normal, no bad bass sounds. It did it in both the dash and soundbar locations. When the eq bass is turned off though, the speaker sounds nice and clean.

Anyone have any idea of what's wrong? These speakers had very good reviews so they shouldn't be doing that just because they're crap.
 

·
Registered
Joined
·
463 Posts
Hey, I just installed some Pioneer TS-G1645R speakers in my mom's 15 JKU to get some clearer sound, but when I tried the new speaker out any bass whatsoever has an awful distorted sound coming from it. It honestly sounds like a fart almost. I left the stock speaker in the other side and it sounded normal, no bad bass sounds. It did it in both the dash and soundbar locations. When the eq bass is turned off though, the speaker sounds nice and clean.

Anyone have any idea of what's wrong? These speakers had very good reviews so they shouldn't be doing that just because they're crap.
Sure you didn't get a bad speaker? I had a set of polks one time that had one that was blown out of the box. Shouldn't sound that bad unless you are over expecting heavy bass and trying to crank it. Hard to know without hearing it.
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #3 ·
Sure you didn't get a bad speaker? I had a set of polks one time that had one that was blown out of the box. Shouldn't sound that bad unless you are over expecting heavy bass and trying to crank it. Hard to know without hearing it.
Sorry, been busy with school and just saw this. I ended up returning them and going back to stock. Determined that the stock head unit didn't have enough power to properly play them. Had it at casual volume and the bass still made this weird noise.
 
1 - 3 of 3 Posts
Top