Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
i have replaced, carburetor,coil,button,cap,plugs,wires, also i thing nutter bypass has been done because i cant find icm ignition control unit. i have a miss at idle and when reving on it but i cant notice it while driving the jeep any one have any ideals on this i would applicate the help thanks stephen
 

·
Registered
Joined
·
421 Posts
Have you checked for a Vac leak?
 

·
Premium Member
Joined
·
2,230 Posts
Is it a steady miss? You can try pulling the plug wires off and on one at a time to see if you can determine which cyl is missing. On some exhuast manifolds you can check which exhaust tube is cooler to determine which cyl is not firing. If you can figure out which one it is you can see if you're getting a spark. If you are sure you have the right cyl and have a spark, you could have a valve or head problem. May be a stuck or sticking valve.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
when its cold and i first crank engine it runs smooth for about 1 min then has a slight miss it was worse until i replaced coil tonay
 

·
Registered
Joined
·
33 Posts
The ignition unit is on the drivers side of the engine bay, by the firewall, all the way down under the two bottles for engine coolant and windshield washer. Small square box with two sets of wires coming out of it.

I had the miss like you are taking about and once I did the Nutter Bypass it went away.
 

·
Registered
Joined
·
139 Posts
Did you buy a referbed Carter? I tried 3 of them.. all would do the same thing.. They drip.. Junk carb.. I switched to a Holley and issue fixed. Ive been told by a few mechanics that when they refurb the carbs they hone out the shaft from the linkage into the carb.. tend to leak air there..Id try to take the carb back and buy a Webber or Holley
 

·
Registered
Joined
·
139 Posts
yep... mine would stall out.. you couldnt get the idle right.. Cold the motor would run right once it warms up it ran way too rich..
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
See I have none of the same it never stalls dissent back fire when on a load or in gear at 15 mph u can't tell. She runs like a champ just a slight miss.
 
1 - 13 of 13 Posts
Top