Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So finally got around to scrapping out the original dist and installed a HEI that I got off ebay. Runs great but the tach does not work. Reading where I need a filter to change signal to the tach. I was in contact with seller on ebay and he says he had never heard of one. Anybody done this upgrade? Dist came from CRT performance.
 

·
Registered
Joined
·
246 Posts
I've got an 89 Islander with 4.2 engine. Installed the HEI distributor and tach worked just fine. I purchased the wiring pigtail to connect both the input power and tach wire. It is an excellent upgrade. Can send a pic or 2 if needed.
 

·
Registered
Joined
·
391 Posts
Same here on my 88', tach worked fine after install.
 

·
Premium Member
'89 YJ 4.2 with MC-2150 Carb & HEI, 2-1/2" Ex. AX-15, NP231 SYE, Adams shafts, F&R ARB, 3
Joined
·
3,971 Posts
What Color is the Tach Wire you are using. Do you have a pic of the tach wireing, If you are using the old tach wire off the Coil it should be fine.
 

·
Registered
Joined
·
890 Posts
The Green wire that went to your ignition coil splice right into the new distributors pigtail. You may not even have to extend it at all. The wire is it green for some reason, it's still whichever wire went to the old coil. Mine is a CRT and it fired up just fine.


Sent from my iPhone using Tapatalk Pro
 
1 - 5 of 5 Posts
Top