Jeep Wrangler Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My 91 4.0 automatic yj has been having a hard time starting. It's isn't temperature specific. It will start but just seems to have a real hard time doing so. When I first turn it over, it will just crank and crank. Then, shake as though it is trying to start. Sometime it does and I just release the ignition. Other times, it wont when I release the ignition. Once it starts, it runs great. I have replaced crank shaft position sensor, throttle position sensor, fuel pump, fuel filter and had vacuum lines cleaned out.

Three mechanics later, no luck. Can anyone help with this!?! I would be so grateful! Also, any referrals for Jeep mechanics in the baltimore area? I would like to fix this on my own but am willing to go to a mechanic if there is a good one out there for such an issue.

Any help is appreciated!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It has a strong crank so I didn't suspect the battery. Would it not have a slow crank if it were that?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
The plugs,wires and distributer were replaced about 5000 miles ago...and they look new....I'm not sure how to measure the strength and consistency but it cranks at what sounds like a strong and normal speed. it almost sounds like a carb engine when it is starting....you know how you have to pump the gas a couple of times to get it started. Except this is injected...

Thank y'all for your help and ideas! I'm at my wits end with this.
 

·
Registered
Joined
·
214 Posts
My 91 4.0 never starts on the first crank. I release the switch and try again and it fires right up. I have been thinking the starter may need a rebuild.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
So I just had advanced auto parts run checks and they said my battery, starter and alternator are all working great. They said it could be the ignition cylinder? Does anyone know if that sounds right?

@bajajohn- I have tried that too but it reacts the same no matter how many times I release...advanced did that check for free...maybe they cold tell you if it does needs to be built.
 

·
Registered
Joined
·
27 Posts
Check the coil. Mine did the EXACT same thing. I checked everything in the ignition system. Troubleshot it down to the coil. Sure enough, when I removed the retrograde, it was cracked (out of sight). Replaced it and works great now.
 

·
Registered
Joined
·
214 Posts
So I just had advanced auto parts run checks and they said my battery, starter and alternator are all working great. They said it could be the ignition cylinder? Does anyone know if that sounds right?

@bajajohn- I have tried that too but it reacts the same no matter how many times I release...advanced did that check for free...maybe they cold tell you if it does needs to be built.

I am lucky I live in Ensenada Baja Mx. we have shops here that actually rebuild things for a fraction of the cost to replace and they are really good at diagnosing the problem,
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Wish I had something like that here...everyone I have gone to so far has been miles from being that good.
 

·
Registered
Joined
·
81 Posts
Check the coil. Mine did the EXACT same thing. I checked everything in the ignition system. Troubleshot it down to the coil. Sure enough, when I removed the retrograde, it was cracked (out of sight). Replaced it and works great now.
I agree. I had a similar issue and turns out it was the coil as well as the connectors on it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
It was the fuel pressure regulator, bad fuel pump (i had just installed it)and leaking o-rings on fuel injectors 3,5, and 6...my reverse lights had stopped workings for was the reverse switch other threads had mentioned! Thanks all for your help!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14
Btw, found a killer shop here in Baltimore called Baltimore Body Shop. In case anyone else reads this thread and needs work done...ask for Tom. These peeps were awesome!
 
1 - 14 of 14 Posts
Top