Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Ok so yesterday my jeep shutdown on me it started losing power I pulled over it stalled out I restarted it had keep pumping gas pedal and run finally it died out and no start I noticed no fuel and the pump was not coming on I towed it home got up this morning and it fired rite up like nothing happened this is the second Time now this has happened anyone else ever had this problem before I replace the pump I just want to do some research it's a 4.0 any ideas
 

·
Registered
Joined
·
15,622 Posts
Either is possible

Knowing fuel trims or o2 sensor readings or fuel rail pressure when if is having trouble would be very helpful
 

·
Registered
Joined
·
1,911 Posts
I had something similar happen to me in my Corvette. 2 hours from home on my way back from a trip to PA. Sat in a parking lot waiting for over an hour for a tow, paid $250 to get it home, he dropped it off the flatbed and it fired right up. Drove it up the driveway and put it in the garage. Said some interesting words to it and went to bed. Next day it fired up great. Drove it around the block. Ended up pushing it halfway back home.

Once the pump got hot it would cut off. I bought a new pump and it ran great.

You can get a fuel pressure gauge and check it.
 

·
Registered
Joined
·
329 Posts
Exact thing happened to me, turned out to be a bad wire to the fuel pump. Check your voltage at the pump and follow the wiring for breaks.
 
1 - 6 of 6 Posts
Top