Jeep Wrangler Forum banner

ABS, ESP, and Traction Control lights

4586 10
Hey all

Got a little bit of an odd one that I need your collective Jeep wisdom with. First off I live about 3 hours from the closest Jeep dealer and only go there if absolutly necessary so that's why I just don't take it in. Alright so everytime I put my 2010 wrangler JKU in reverse the ABS, ESP, and traction control lights come on and it dings. Then when I put it in Drive or Park the lights go out. The vehicle does not appear to be negatively impacted when in reverse, however the traction control does not activate...although I am not 100% sure it is supposed to be active in reverse....anyways....so what ya'll think? Sensor? ECU? whole system? tiny lepricon?

Let me know!

Thanks
1 - 11 of 11 Posts

·
Premium Member
Joined
·
353 Posts
Discussion Starter · #5 ·
We recently had a pretty harsh snow/ice storm with lots of slush and freezing rain
 

·
Registered
Joined
·
36 Posts
Strange it only happens in reverse. :confused:
you have a good point there!


I hear of this happening with more and more JK's... I wonder what could be going on? Mine goes on when i run through water holes and after multiple days of mudding... But even then it comes on for a few minutes and then goes off...
 

·
Premium Member
Joined
·
353 Posts
Discussion Starter · #10 ·
Well the dealership removed a few pounds of mucky clay off my chassis...and lectured me about keeping the jeep clean...which I chuckled at a bit. I haven't had the issue since..so dirty sensor seems to be issue
 

·
Registered
Joined
·
10 Posts
Help

I know this thread is old, but while taking off today my Jeep felt weird and then my ABS, ESP and traction control lights came on. Felt like it was hard to pick up speed. I pulled over, turned off the ignition, waited a few minutes, turned back on and it did the same thing. I can't get it to my mechanic until Wed, (today is Monday) will it hurt to drive it like this?
I have a 2010 Jeep Wrangler Unlimited Sport 4wd.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top