Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have ABS/Traction control lights on my 2016 willys. I have seen a lot about wheel speed sensors causing this. I have already replaced the front sensors and cleaned the back as they were covered in break dust and reset the computer by disconnection the battery over night.


the weird thing about my problem is my spedo is dancing all over the place and the transmission doesn't want to shift out of 2nd gear. The breaks also stutter when moving most of the time causing it to go into limp mode. I had the computer scanned at an autozone and the only code that showed up was for a transmission speed sensor module (cant remember the actual code). this part is $300 alone and looks like it actually goes inside the transmission. i cant seem to find anything online on this part going out on someone so im confused.



I have had this jeep for less than a year and it has under 30k miles on it bone stock other than an after market front bumper and light bar that came with the jeep. its at the dealership right now and ill know more in a day or 2. just curious if anyone has come across something like this before.
 

·
Retired Moderator
Joined
·
100,487 Posts
:welcome: to the Forum..:wavey:
 

·
WF approved Offical Jeep Account.
Joined
·
1,567 Posts
I have ABS/Traction control lights on my 2016 willys. I have seen a lot about wheel speed sensors causing this. I have already replaced the front sensors and cleaned the back as they were covered in break dust and reset the computer by disconnection the battery over night.


the weird thing about my problem is my spedo is dancing all over the place and the transmission doesn't want to shift out of 2nd gear. The breaks also stutter when moving most of the time causing it to go into limp mode. I had the computer scanned at an autozone and the only code that showed up was for a transmission speed sensor module (cant remember the actual code). this part is $300 alone and looks like it actually goes inside the transmission. i cant seem to find anything online on this part going out on someone so im confused.



I have had this jeep for less than a year and it has under 30k miles on it bone stock other than an after market front bumper and light bar that came with the jeep. its at the dealership right now and ill know more in a day or 2. just curious if anyone has come across something like this before.
Should you need any assistance while working with your dealer, please do not hesitate to send our team a PM. We'd be happy to connect you with a Case Specialist to assist.
Alex
JeepCares
 
1 - 4 of 4 Posts
Top