Jeep Wrangler Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have just installed a kenwood DDX719 in a 2012 JK. Included in the install is a PACinterface PAC RP4 CH11 to maintain steering controls for the volume and such. After install everything worked perfect however after removing the head unit to install a backup camera I blew a inline fuse to the interface. After replacing the fuse I have now lost accessory power. Many of you are probably thinking check the fuse in the fusebox for an additional fuse that may be blown. When I mean lost accessory power I mean the stereo will now turn on and off without the key in the ignition if it was directly connected to the battery. Before I blew the inline fuse on the ACC wire it worked fine. Any suggestions? I called PAC and they had no clue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I did, everything works fine it just will not turn on or off when I turn the key and open door the because of the delay. Before the blown fuse it worked fine. All the wires are hard wired into a harness. It's as if it is bypassing the acc
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
All connections are good, all I did was replace a 1amp fuse and now this. The stereo works fine the interface still controls the steering controls but it's like it is bypassing the ACC power
 

·
Registered
Joined
·
26,921 Posts
There is fused battery power to the stock radio at all times. If the new harness plugs into the stock harness, the new radio likely has power to it at all times. Perhaps the interface got damaged when the fuse blew.
 
1 - 6 of 6 Posts
Top