Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 17 of 17 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
After doing a complete rear brakes job (pads, rotors, caliper bracket & ABS sensor) on my 2012 Jeep Wrangler Sahara myself, we ran into several problems. The sensors were after market from NAPA as were all the other parts. The dash is still showing ABS traction alert. It's now also showing the emergency brake alert and a engine light alert. To make matters worse, my transmission will now not shift out of 1st gear nor will the auto shift stick show 1st or 2nd when I try to use it manually. It's at the dealer now. Rep said it sounds like the sensors are screwing up the computer since it is after market sensors. Any one else experienced anything like this? The transmission issue showed up the day after the sensor & brake replacements.
 

·
Premium Member
Joined
·
2,468 Posts
Sounds like you still have a defective sensor causing the transmission to into limp mode. The shop will test them, replace the defective one and you’ll be good to go.
 

·
Super Moderator
Joined
·
10,615 Posts
Moved it to the JK section. You should get more responses here.

:welcome: to the forum!
 

·
Retired Moderator
Joined
·
100,490 Posts
:welcome: to the Forum..:wavey:
 
  • Like
Reactions: jabro

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
Yes, diagnostics at the Dealer repair had codes listed for both rear sensors even though we replaced both with Napa sensors. Rep said the same thing as Lee. However, Emergency brake shoes were compromised during brake job. Now they say it will cost $1000 for repair plus the sensor repair.
 

·
Premium Member
Joined
·
2,468 Posts
You need to find a local shop to do your repairs. You don’t need the dealers at this point. You will save a bunch of money and get better quality repairs.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #11 ·
New England weather and husband's surgery prevents us from repairing it ourselves. Dealership will be having a Merry Xmas with our $$.
 

·
Registered
Joined
·
6,696 Posts
You go into limp mode with 2 or more abs sensors not working properly. The limp mode should clear up after you clear up the sensor issues
 

·
Registered
Joined
·
10 Posts
I was told from a local garage that even if problem is repaired,if you don't have a big $ scanner you can't clear codes,may clear temporary but dash lights will come back on
 

·
Registered
Joined
·
6,696 Posts
I was told from a local garage that even if problem is repaired,if you don't have a big $ scanner you can't clear codes,may clear temporary but dash lights will come back on

HUH?

Most (inexpensive) scanners will clear codes now after repair is done. The only way the light will come back on is with an improper repair that does not clear the issue.
 

·
Registered
Joined
·
2,949 Posts
I was told from a local garage that even if problem is repaired,if you don't have a big $ scanner you can't clear codes,may clear temporary but dash lights will come back on
The garage is full of bovine excrement.
Once the sensor issue is fixed, the abs lights will reset.

That is BS I would have expected from the dealer.

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
722 Posts
I have replaced both front sensors with aftermarket sensors from O'Reiliys and cleared the corresponding codes with my cheap Bocsh scanner. Something doesn't sound right.
 
1 - 17 of 17 Posts
Top