Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi guys,

I have the Alpine WRA X106 indash system and lately its been spontaneously turning off byself. Some time later while driving (could be 5 mins or 30 mins or not at all during the drive) it turns itself back on (and could turn off again within minutes). I have had this problem before and what I did was "reflash" the idata maestro device and the problem was "solved" for some months until it happened again.

Does anyone know or have any idea as to why it happens? Any idea how it could be permanently fixed?

Do factory screen radios also spontaneously turn off by themselves?

Thanks for any info!!!
 

·
Registered
Joined
·
1,979 Posts
No, the factory radios do not turn off by themselves...unless they have gotten wet.

The Alpine units are pretty solid. The Maestro module appears to be the weak link that is the source of many of the issues that crop up when going aftermarket. It is a great unit when it works well, and is capable of quite a lot, but it appears to be sensitive. If your Maestro module is still under warranty, that may be a good place to start.
 

·
Registered
Joined
·
6,704 Posts
I wonder if the red wire on the Maestro has anything to do with it. The red wire (or 12 volts while in run or accessory) is not in the original jeep harness, but must be there so the radio turns off and on with the key.


Since the jeep harness doesn't have this wire, the maestro has to generate it. Given that, what you can try doing is cutting the head unit red wire from the maestro and connecting it to the positive on the 12 volt outlet on the dash.
 
1 - 3 of 3 Posts
Top