Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
509 Posts
Discussion Starter · #1 ·
Hello all:

I have an occasional problem with my 2014 Willys, and I wonder if I'm not the only one. Sometimes, on the hiway at 70 mph, with the cruise on, if I hit a rough patch of road, the cruise will shut off. My thought is that this is caused by ESC, but there is a slim chance that I'm wrong...could it be the traction control doing it?

If it is ESC, is there a way to disable it on my 2014? Driving to work in the winter time, on icy or snowy hiways, I can see why it would disengage the cruise if you started to slip or lose traction. But driving on dry roads in the summer, it seems sort of dumb (and potentially dangerous) to immediately disengage cruise just because of a couple of small bumps.

Any thoughts, opinions, etc would be much appreciated.
 

·
Registered
Joined
·
144 Posts
Happens to me too, its the ESC. There is a button the dash to turn off the traction control, but I haven't tried to see if it cures this problem but it doesn't matter to me that much.
 

·
Registered
Joined
·
2,253 Posts
Interesting, my 2013 with the same leveling kit the OP has doesn't do this at all, sounds like something is amiss.
 

·
Registered
Joined
·
3,710 Posts
I posted the same problem last year. There was not much of a solution available. Dealer said they couldn't reproduce so naturally there is no problem..... Smh.

Still does it. I also feel it is dangerous. Makes a very halting force on the vehicle.

Sorry I'm not any help. But I know what you are talking about and feel for you.


13 jkur 6sp 27k miles btw.
 
1 - 6 of 6 Posts
Top