Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Searched the forum as well as Google and still am stuck. Here's my scenario

Son has jeep at college (03 Wrangler X). Calls says it's not starting. Everything working and lights do not dim when trying to start. Says no clicking noise, so I assume ignition actuator pin. I go to his school replace that, still nothing but I am hearing clicking in the relay. So replace the starter. Now everything works fine, including wipers, signals, blower motor etc, but no radio including light/clock. When we did the work we did disconnect battery, but positive cable.

I have read since then, disconnecting positive can cause problems with radio.electronics. I have disconnected battery over night, I touched both cables together (read that somewhere) and of course checked the fuses (PDC and behind glove box) No radio. Everything else is fine.

I have not torn radio out to see if power getting to it and if I have to do that will have to wait until home from school. Wondering if there is an easy fix I have missed my son can try.

Thanks for your help
 

·
Registered
Joined
·
810 Posts
You have to worry about the arc when you reconnect the battery if you only took the positive loose. It can damage sensitive circuits, fry the alternator, etc. Only thing left to do if the fuse is good, is to pull the radio and see if there is power. If there is, it's time for a new radio.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
OK gonna tackle this over Thanksgiving, but wondering if when I replaced the ignition actuator pin I actually had to remove the ignition lock cylinder. Like I said previously everything works with the ignition on except radio. I was wondering if I could have put the lock cylinder in incorrectly or actuator pin assembly that would cause radio not to work.

Lastly what is best way to determine if there is power getting to radio? Thanks
 
1 - 4 of 4 Posts
Top