Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
929 Posts
Yes mine's been doing it for like 3 years..it's annoying and another effect of this is the AC going completely off for like 10 minutes while it resets. My first assumption was that it's doing a check (the computer) and that's why it delays. My Jeep is already out of warranty so I'm just waiting for the ultimate fail. Hopefully it never comes because Texas is hot as hell right now.
 

·
Registered
Joined
·
115 Posts
It's all electronics so it takes awhile as opposed to you cranking the vent over like you would in older vehicles
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I understand it's all electronics. But it never did that before. Recently just started about 2 days ago. It used to take about 3-5 seconds to kick in now it takes about 30
 

·
Super Moderator
Joined
·
23,754 Posts
mine did that and I took it in and they replaced a module under warranty. part number is
68197437ab it is the hvac module.
 

·
Registered
Joined
·
6,299 Posts
It is supposed to take a few seconds to start. It's called "purge mode".

Why yours takes so much longer I dont have a clue.

"It’s called “purge mode”. The function is two fold; it dries out the evaporator for six seconds and blows all that musty air out the floor ducts at minimum blower speed to prevent the customer from smelling it, and it also prevents “flash fog” from building on the windshield in the winter months. The purge mode should only be active if the car has been left alone for ten minutes or more. "
 

·
Registered
Joined
·
736 Posts
mine takes about 30 sec to kick on in real hot weather.
but when it does kick on, its immediately cold.
so I don't really see it as a problem
 

·
Registered
Joined
·
736 Posts
is it an exact 30 sec.?
I don't know..I never actually timed it.
could be 20.
I did notice tho that the delay isn't constant.
the cooler it is the shorter the delay,
when its 96'-97' out the delay is a bit longer and is more noticeable because you want the air
 

·
Premium Member
Joined
·
9,626 Posts
mine did that and I took it in and they replaced a module under warranty. part number is
68197437ab it is the hvac module.
This. Mine went out not to long ago. If under warranty free, otherwise a little over $100.
 

·
Registered
Joined
·
23 Posts
If your defrost light is blinking while you're not receiving air from the vents. You have a faulty HVAC Control Module. Its the board connected to the controls. I had mine replaced under warranty after battling it for a year.
 
1 - 12 of 12 Posts
Top