Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Good afternoon friends,

I have a 2016 JKU Sport stock with Communication package. I had no issues with my radio or speakers for months. About 4 months ago, I installed some waketower speakers and amp ran through a PAC AOEM-CHR3 System Interface Kit, so I would not have to replace head units, or add any additional parts to continue to use my steering wheel controls. In the last month, the only speakers that play music are my newly installed waketower speakers. So I was thinking that maybe just maybe, I blew all of the speakers. But here is the kicker, I tried making a phone call, and the other individual's voice was coming through on my speakers that were not playing music! So, I'm to the point where I want to pull apart the dash and check wiring connections first. But has anyone else experienced issues like this? If so, what did you do to fix the speakers to emit music again?

I appreciate the help in advance! :atomic:
 

·
Registered
Joined
·
2,468 Posts
Sounds like an incorrect wiring job.

From the manual:

3. Make all connections as described in the connection chart on page 1.

Vehicles without a factory amplifier: Connect the aftermarket radio’s front and rear speaker wires to the vehicle connector.

Vehicles with a factory amplifier: The factory amplifier only accepts two channels of audio input (left and right). Connect the front outputs of the aftermarket radio to the rear inputs of the vehicle connector. This will allow navigation voice prompts and Bluetooth calls to be heard. The rear speaker outputs of the aftermarket radio are not used. Fading is not supported in this application. The factory amplifier’s fading is controlled by data communication from the factory radio. Neither the aftermarket radio or the RP interface have the ability to control the amplifier’s fader.
 
1 - 2 of 2 Posts
Top