Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
3 Posts
Discussion Starter #1
Hi there,

Here is my problem. I just installed a Currier Dana 44 Rockjock front end, with a brand new gears ratio 4.88 and a Elocker. With that a 3.5" TeraFlex lift.

Here is my issue, when turn, there is massive grinding and chirping. It is definitely worse when I turn all the way, but it starts when I go from straight to turn.

I can feel that when I turn the wheel something starts rubbing. When I say rubbing, it is metal on metal. It almost sounds like it is coming from the wheel ends.

Help!!
 

·
Registered
Joined
·
878 Posts
Lift the front axle onto jack stands and have someone help you by turning the wheel to full lock in each direction to find what is rubbing.


Also, spin each tire to insure that the locker is not engaged when it shouldn't be. If you start noticing the problem immediately when you start turning I'd suspect a locker issue.
 

·
Premium Member
Joined
·
3 Posts
Discussion Starter #6
Thanks All!!

I'm going to pull apart the axle and see if there is any wear on the shafts.

To answer a few of the other questions:

  • Dry Pavement
  • Not the sway bar links. Plus this is metal metal, as far as I can tell via sound.
One thing I have not done, is cycle the Elocker, which I'm going to try, after I do the inspection.

The sucky part, is I bought a completed axle, so I didn't put this together, just installing it.
 

·
Premium Member
Joined
·
3 Posts
Discussion Starter #7
Well found my issue, seems that Eaton Elockers, made their journal small because they didn’t originally intend for it to work with front Rubicon shafts. Basically the shaft was stuck and I mean stuck in there. With help from the tam I bought it from (NorthRidge 4x4) we where able to get it out AND they sent me a new shaft that had been honed down by .030"
 
1 - 7 of 7 Posts
Top