Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 17 of 17 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Good Evening All,
I have a 2018 JLU Sahara with upgraded radio/display. The guidlelines to my backup camera have disappeared. I uncheck and recheck it in settings but no help. This is the third time it has happened and, in the past, it has come back after a few starts. Anyone else seeing this? Can this be fixed? This pattern of something going away and then coming back after a few starts has also happened with my audio sound going and the touchscreen display buttons (radio, climate, etc at the bottom of the screen). I have not taken this into the dealership because I fear it will be unproductive since its a problem that can't be reproduced unless they drive my Jeep for a few weeks. These same issues have been mentioned on this and other forums for the JLs so I know I'm not crazy or alone. Is JeepCares still out there? I love my Jeep, but these issues which come up every few weeks and then go away are starting to really bother me. Thanks.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
My apologies for not doing a better job of searching this forum before my post. Top Shelf posted the same problem on Sep. 10, 2019. However, I remain hopeful someone out there will have some good advice for Top Shelf, myself, and all the others out there with this issue. Thanks.
 

·
WF approved Offical Jeep Account.
Joined
·
1,575 Posts
My apologies for not doing a better job of searching this forum before my post. Top Shelf posted the same problem on Sep. 10, 2019. However, I remain hopeful someone out there will have some good advice for Top Shelf, myself, and all the others out there with this issue. Thanks.
Hi @MyFirstWrangler2018,

If you send us a private message with your VIN, we can look for any applicable TSBs for this back-up camera issue.

Darlene
Jeep Social Care Specialist
 

·
Registered
Joined
·
13 Posts
Hi @MyFirstWrangler2018,

If you send us a private message with your VIN, we can look for any applicable TSBs for this back-up camera issue.

Darlene
Jeep Social Care Specialist
I bought a brand new 2021 Rubicon and it's doing the same thing. The guidelines will work, then they don't. On and off. I took it to our service jeep dealer and he saw the problem when he put it in reverse. And they still couldn't find a problem??? I had to take the car back and he told me to call if it happens again. Which it did! So now I have to go back again and drop the Jeep off. There has to be an easy fix since this is happening to other Jeeps?
 

·
WF approved Offical Jeep Account.
Joined
·
1,575 Posts
I bought a brand new 2021 Rubicon and it's doing the same thing. The guidelines will work, then they don't. On and off. I took it to our service jeep dealer and he saw the problem when he put it in reverse. And they still couldn't find a problem??? I had to take the car back and he told me to call if it happens again. Which it did! So now I have to go back again and drop the Jeep off. There has to be an easy fix since this is happening to other Jeeps?
Hi Misty,

I'm sorry to hear about the experience you're having while trying to get your concerns addressed. Please feel free to send us a private message so we can offer our additional support alongside your service appointment.

Thanks!

Courtney
Jeep Cares
 

·
Registered
Joined
·
17 Posts
This is a very common issue with the JL Backup camera. Generally very intermittent. I've video'd it and showed it to the dealership the last few times that I have been in. Unfortunately several of their service managers confirmed that while they have seen the issue on multiple jeeps, there is no consistent fix. They have offered to flash the software, did that once, but no real difference.

It's pretty intermittent, and the lines come on more than they don't....so I've just been living with it as many others have.
 

·
Registered
Joined
·
26 Posts
This is a very common issue with the JL Backup camera. Generally very intermittent. I've video'd it and showed it to the dealership the last few times that I have been in. Unfortunately several of their service managers confirmed that while they have seen the issue on multiple jeeps, there is no consistent fix. They have offered to flash the software, did that once, but no real difference.

It's pretty intermittent, and the lines come on more than they don't....so I've just been living with it as many others have.
On my 2021, the lines are gone MUCH more than they're present. My ride is in the shop for its second time on this problem right now. It's been two days, and still no fix. :mad:
 

·
Registered
Joined
·
13 Posts
Hi Misty,

I'm sorry to hear about the experience you're having while trying to get your concerns addressed. Please feel free to send us a private message so we can offer our additional support alongside your service appointment.

Thanks!

Courtney
Jeep Cares
How do I send you a private message?
 

·
Registered
Joined
·
1 Posts
Brand new forum member with a brand new Wrangler. I’ve owned it for three days, and 100 miles. The lines on the backup camera showed up for the first two days, and now they don’t. I plan to get it into the dealer within the next day or two. But this thread isn’t encouraging, both because the problem may be one of those that comes and goes, and because it doesn’t sound like dealers know a fix.

Has anyone succeeded in getting the issue fixed?
 

·
Retired Moderator
Joined
·
100,727 Posts
Brand new forum member with a brand new Wrangler. I’ve owned it for three days, and 100 miles. The lines on the backup camera showed up for the first two days, and now they don’t. I plan to get it into the dealer within the next day or two. But this thread isn’t encouraging, both because the problem may be one of those that comes and goes, and because it doesn’t sound like dealers know a fix.

Has anyone succeeded in getting the issue fixed?
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
Joined
·
93 Posts
I bought a brand new 2021 Rubicon and it's doing the same thing. The guidelines will work, then they don't. On and off. I took it to our service jeep dealer and he saw the problem when he put it in reverse. And they still couldn't find a problem??? I had to take the car back and he told me to call if it happens again. Which it did! So now I have to go back again and drop the Jeep off. There has to be an easy fix since this is happening to other Jeeps?
I bought a new 2021 JLU Sahara about 5 weeks ago... Backup camera worked fine for about 2 weeks... After that it's a crap shoot between, lines, no lines or NO camera at all, just a black screen...

I'm not super excited about it right now, but want it fixed at some point, and fixed RIGHT!
 

·
Registered
Joined
·
13 Posts
Brand new forum member with a brand new Wrangler. I’ve owned it for three days, and 100 miles. The lines on the backup camera showed up for the first two days, and now they don’t. I plan to get it into the dealer within the next day or two. But this thread isn’t encouraging, both because the problem may be one of those that comes and goes, and because it doesn’t sound like dealers know a fix.

Has anyone succeeded in getting the issue fixed?
Not Yet! Same thing with me. Brand new Rubicon and it started right away. Two visits to the dealer and still no resolution. Somebody here said in June there's supposed to be a software update to fix it. I am waiting to see what happens :( Let me know if you find anything out....
 

·
Registered
Joined
·
1 Posts
I just purchased a 2021 Jeep Sahara two weeks ago and I already have the same problem. My active guidelines no longer show when i am in reverse. I have checked the settings and everything is checked correctly. Has Jeep created a patch to fix this issue?
 

·
Retired Moderator
Joined
·
100,727 Posts
I just purchased a 2021 Jeep Sahara two weeks ago and I already have the same problem. My active guidelines no longer show when i am in reverse. I have checked the settings and everything is checked correctly. Has Jeep created a patch to fix this issue?
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
2021 Jeep Wrangler Rubicon Diesel, Sting Gray
Joined
·
79 Posts
I have a 2021 Rubicon Diesel. THis morning backed out, no lines. It has around 630 miles on it...grr.
 

·
Registered
Joined
·
194 Posts
LOL, same here. It’s intermittent.
I‘m posting to document & to ensure Jeep Cares is aware of this issue, hoping JC pushes this issue up to Stellantis for future remedy.
Cheers all/B
 
1 - 17 of 17 Posts
Top