Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 61 Posts

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #1 ·
The JL has 1,100 miles: the navigation started acting up yesterday; it would get stuck on the loading screen indefinitely but would self-rectify after turning the Jeep off and on.

This evening the backup camera stopped working altogether. The “Check Surroundings” text appears but the screen goes blank.

Has anyone had this happen? Any quick fixes?

Thanks in advance.
 

·
Super Moderator
Joined
·
2,725 Posts
Quick fix is to try rebooting it by pulling fuse F11 (and/or F97) in your fuse box under the passenger side of the hood next to the battery.

If that doesn’t work it may need a software update.
 

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #3 ·
Quick fix is to try rebooting it by pulling fuse F11 (and/or F97) in your fuse box under the passenger side of the hood next to the battery.

If that doesn’t work it may need a software update.
Awesome! I will try that. Thanks!
 

·
Super Moderator
Joined
·
23,754 Posts
Just the Jeep gods messing with you for leaving the fold for a Toyota...
 

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #7 · (Edited)
Just the Jeep gods messing with you for leaving the fold for a Toyota...
More like the Jeep ghosts...LOL

Speaking of ghosts, my JL makes this spooky sound when I back out the driveway. At first I thought I was in an episode of the Twilight Zone, but it does it all the time.

Must be the spirit of Sergio Marchionne...
 

·
Premium Member
Joined
·
16,902 Posts
The JL has 1,100 miles: the navigation started acting up yesterday; it would get stuck on the loading screen indefinitely but would self-rectify after turning the Jeep off and on.

This evening the backup camera stopped working altogether. The “Check Surroundings” text appears but the screen goes blank.

Has anyone had this happen? Any quick fixes?

Thanks in advance.
Mine did it once, shortly after I got the Jeep. That was about a year ago.

Since then it has done a couple other things (once).

I dunno. I wish other people and "things" in my life only acted up - Once. :)
 

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #9 · (Edited)
After removing the fuses and the backup camera started working again, the display screen now randomly switches back and forth between the main landing screen and the map screen, erratically flashing, for a split second, parts of the map on the main screen and quickly disappearing.

My Jeep emailed me a Vehicle Health Report (VHR) yesterday, telling me what the tire pressure is on each tire, that all fluid levels are okay, and that it has no TSBs pending. But apparently my Jeep is completely unaware that its own head unit is going loco! :crazy:
 

·
Super Moderator
Joined
·
23,754 Posts
scary
 

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #15 ·
Yeah.

I’ll wait for the HU to croak completely before going to the dealership. Unless it is obviously broken, those f*ckers are not going to lift a finger.
 

·
Premium Member
Joined
·
10,147 Posts
There's that old saying... you can run, but you can't hide.

.
 
  • Like
Reactions: aldo90731

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #17 ·
Drove the Jeep 100 miles over the weekend: the navigation issues appear to have self-corrected.

We will see for how long...
 

·
Premium Member
Joined
·
16,902 Posts
Drove the Jeep 100 miles over the weekend: the navigation issues appear to have self-corrected.

We will see for how long...
Thought there a smattering of issues (?) As far as Navigation .... I don't even use mine because in a word - it's wacked.
I use my phone. Head to Head, phone wins hands down.
 

·
Super Moderator
Joined
·
10,635 Posts
Discussion Starter · #19 · (Edited)
Thought there a smattering of issues (?) As far as Navigation .... I don't even use mine because in a word - it's wacked.
I use my phone. Head to Head, phone wins hands down.
Indeed. The backup camera started working again and the navigation stopped getting stuck on “loading” after I pulled the fuse on Thursday. Then on Friday parts of the navigation screen starting popping on-and-off on the main screen; the latter appeared to have self corrected by EO weekend. Fingers crossed!

I’m trying to avoid going to my local Jeep dealership. In fact, I rather have all my teeth pulled out without anestesia, than step into that dealership...

 

·
Premium Member
Joined
·
16,902 Posts
Indeed. The backup camera started working again and the navigation stopped getting stuck on “loading” after I pulled the fuse on Thursday. Then on Friday parts of the navigation screen starting popping on-and-off on the main screen; the latter appeared to have self corrected by EO weekend. Fingers crossed!

I’m trying to avoid going to my local Jeep dealership. In fact, I rather have all my teeth pulled out without anestesia, than step into that dealership...
Yours (hopefully) may have been like mine.... a brief hiccup about a year ago and that was it.
Everything I buy these days (phones, computers, Tv's, etc etc ) I expect glitches. That way I'm rarely disappointed.
 
1 - 20 of 61 Posts
Top