Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Basically my jeep is my dd and gets driven a lot. Lately I have had this super annoying problem where if its driven for over 10 or 15 minutes when I come to a light is shakes. Here is the weird part, it shakes as if the ac compressor was kicking on an cycles on and off like that till I gas out of it and go. It sputters a bit when I go then it drives fine. It'll do it a handful of times and stops for the rest of the drive. My ac is never used cause it sucks too much power from the 2.5 while driving. So no, its not the ac compressor. Recently it started stalling at lights, its done it twice in the past month. It will shake violently then shut off. A small amount of hesitation at start up then it seems fine. I was reading TPS sensor could cause similar symptoms, but it also said it would throw a code. I check for codes often and never seen a tps code. I've cleaned the throttle body, fuel rail, new plugs and wires (less than a year ago), new distributor and rotor, checked for vacuum leaks.I mean I'm getting frustrated nothing is helping and I'm at a loss. Which is why I am here. Hoping someone else has had a problem like this that can shed some light on it.

Its a 2002 tj 2.5L with 33s and a 4 inch lift.
 

·
Registered
Joined
·
306 Posts
Hmm...is it shaking at lights because of low rpms? I know you've said you cleaned the throttle body, but did you make sure to take the IAC out and thoroughly clean it with carb cleaner?
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
Hmm...is it shaking at lights because of low rpms? I know you've said you cleaned the throttle body, but did you make sure to take the IAC out and thoroughly clean it with carb cleaner?
Yea it was cleaned out good. The rpms, it's hard to tell. My needle sticks because I put a back lit panel on there and it needs to be adjusted. The needle only moves above 1000 rpm. I have to bang on the dash to get it to lower and it just sits there.

Could this be fuel related? I just don't get why it cycles. It will start the vibrations do it for about 5 seconds then off again, rinse and repeat.
 

·
Registered
Joined
·
161 Posts
If you have idle RPM surges and stalling but running well at higher RPMs then it is most likely an IAC motor. (Idle Air Control). Usually located near the throttle plate.
 

·
Registered
Joined
·
118 Posts
I have a similar issue thats been happening for a year now, I've replaced my o2 sensors, tps, cleaned the TB, cleaned the IAC, checked for vacuum leaks. I am going to replace the IAC next to see if thats the issue, which would be weird considering I have zero codes.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
I have a similar issue thats been happening for a year now, I've replaced my o2 sensors, tps, cleaned the TB, cleaned the IAC, checked for vacuum leaks. I am going to replace the IAC next to see if thats the issue, which would be weird considering I have zero codes.

I think I have mine figured out. Its oddly funny. I started having brake issues so I checked the master cylinder and it was very low. I put more fluid in bled the brakes and since I did this, my issues have gone away. I have driven it to work (rode him hard, which usually triggers it) and not a single shake at idle any more. The only thing I've done lately is check my pads and filled up the brake fluid. As for the stalling, still none. It drives like a jeep should now. Still gets heat soak, but that's another battle :pullinghair:

Its only been 3 days since I did this so I will post if things change.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
I haven't found one yet. But I also haven't taken the back tires off to check the drums. I don't see any leaks on the tires or anywhere else though. I've been keeping an eye on the level and it doesn't seem to be dropping.
 

·
Registered
Joined
·
161 Posts
Sometimes the fluid drains into the brake booster and the leak does not show up until later.
 
1 - 10 of 10 Posts
Top