Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I have a 1989 Wrangler. It has always started with no problem. It sat for about 2 weeks, weather turned cool and it would not start. I jumped it off and drove about 10 miles, but still would not start. I jumper it off again with no problem. I noticed after it started I heard a clicking noise coming from what looks to be a type of module mounted on the bracket beside the battery. It says Dueltech Electronics on it. I had the battery checked and they said it was ok and just needed charging. I had never heard the clicking sound before. Any ideas?
Mike
 

·
Registered
Joined
·
29 Posts
Discussion Starter #2
any idea what the module is? After I jumped it off and was disconnecting the jumper cables I heard a clicking sound coming from it.
 

·
Registered
Joined
·
223 Posts
If you let your jeep sit and want to disconnect the battery, take the negative cable off. taking the positive off can (not likely) create an electrical surge and can effect some electronics in the jeep (computer), its just a good habit. as far as checking the battery, a battery can NOT be checked to see if its good if it does not have a charge. i would charge the battery then have it checked. but if i had to guess i would say its the battery,there are alot of electronic battery testers out there that will take all of the guess work out..
 

·
Registered
Joined
·
8,968 Posts
I would replace the battery. I don't know who checked your battery and said it's ok just needs to be charged, it doesn't work that way. If you don't want to get stuck replace it.
 
1 - 4 of 4 Posts
Top