Jeep Wrangler Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter #1
So my blower motor only works on speed four, not 1-3. I replaced the blower motor resistor which did nothing. Today I wiggled the wires around and got everything to work, when I tested it a couple of times it stopped working. I noticed that the relay that comes from these wires was warm-hot. What could be the issue? Thanks guys!
 

·
Registered
Joined
·
552 Posts
Same with my 06

:popcorn:
Mine is getting there. Speeds 1-3 you hardly know they are on but full power works great. Im worried that max power will soon follow the other three and stop working.
Mine is an 06TJ
 

·
Registered
Joined
·
831 Posts
I've had mystery AC the last few weeks. Sometimes the fan blows ....sometimes not. I've not had time to play with it.....thank goodness it's only a weekend run around vehicle for me.
 

·
Registered
Joined
·
3,286 Posts
Mine was the fan speed switch, works fine since then.
 

·
Registered
Joined
·
831 Posts
Also realize now
that when my air bag light comes on the fan goes off ? Happened twice today headed over to the beach. Left in the heat without AC and air bag light on......20 minutes later while pulling into a store parking lot the AC fan came on and the airbag light light went off.....crazy!
 

·
Premium Member
Joined
·
767 Posts
Mine was the fan speed switch, works fine since then.
Same here... replaced the fan speed switch and all three knobs about two years ago and everything still works fine but I notice that the blower door switch knob (aftermarket metal knob) gets super hot after a while whether I'm running heat or AC. I know that if it were the OEM plastic knob that it would have melted by now. Somethin ain't right in there but it all continues to work well. I posted a Q about this a while back but got no responses.
 

·
Registered
Joined
·
411 Posts
You guys have to do mod to put in relays for the blower motor. No more hot switches which cause the erratic fan behavior
 

·
Registered
Joined
·
110 Posts
:popcorn: ya, I only have 1,2 and 4. Since I don't have ac... it's not even really worth it turning the air on. I usually just open a window rain or shine.
 

·
Registered
Joined
·
9 Posts
I had a similar problem on my 97. I found the grease on my slide lever for Vent...AC...Heater...etc had thickened and was intermittently allowing the motor to run and not run. I cleaned the switch with some spray degreaser and applied a new light coat of grease. It's worked fine since.
 

·
Registered
Joined
·
831 Posts
Mine appears to be allot more electrical. I played with it last night and my back up lights are also out when my air bag light is on.

Googling at now and there are several posts about Wranglers with similar issues of no A.C fan and no back up lights when the air bag light is on. What i have not found is the solution. Some have posted their problem was solved with an ignition change, but not all.
 

·
Registered
Joined
·
195 Posts
This is the same mod in the thread posted in post #4 of this thread. Maybe a little easier to read.

Look at post #50 in this thread and check for melted connector where the picture says "this switch here". Do the relay mod shown in the thread and that plug and the fan switch will not melt again.
Fried A/C speed switch w/pics! - Page 2 - JeepForum.com
 

·
Registered
Joined
·
2,294 Posts
Pulling this back up to get some clarification on a question or two I have.

I have a 1999 with A/C

I ordered the VDO Blower (which apparently some like, and some don't) and the switch assembly from www.rockauto.com simply because I am in the midst of a huge home project and when I dig into my A/C issue I want to have the parts to fix it on hand. One day out of the blue my blower stopped working on all speeds. A/C compressor still works, and I have not tracked the ground or power to the blower or the switch. I do have power all the way to the A/C fuse at the glove box.

I've read about the relay mod, and if I understand correctly you don't need to add a relay if you replace the blower motor. There's 155k on the clock before the stock switch went (if that's in fact what it is) so is it safe to say that I could expect similar longevity from the replacement switch as long as I replace the blower motor also?

Please refrain from giving me crap about buying the parts without knowing the problem 100%, it's simply a convenient luxury for me to be able to do so. I'm so deep into projects at work and home that I'm actually dropping off my motorcycle to get rocker box gaskets installed at a shop. :(

If I need to wire up relays I probably could, but I'm not much of an electrician.
 

·
Registered
Joined
·
127 Posts
Strange but after reading this thread I decided to go out and check my fan and heater/AC.
Everything works great except setting number 3. 1,2 and 4 work.

what the poop is that ?

:pc-ouch:
 

·
Registered
Joined
·
2,294 Posts
I searched, I found the relevant thread, I posed a question with some good points of inquiry, and I got nothing useful. I guess I understand why everyone just starts a new A/C blower thread each day instead of trying to keep it all in one place. Oh well, I'll let y'all know how it works out and what I do when I get to it.
 

·
Registered
Joined
·
831 Posts
After a few months of frustration I have my issue corrected. My problem was when started, the air bag light would come on, my AC fan would stop (compresser stayed on), and my back up lights would go out.

I had the ignition replaced and all seems well!
 
1 - 18 of 18 Posts
Top