Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
750 Posts
Discussion Starter · #1 ·
When i have my pandora playing from my phonwe via bluetooth in the rubi it skips like a scratched cd on almost every song? Phone is in cup holder. No problems from the girl's phone when she hooks hers up. No issues when i pair my phone to my truck or any other devices i use. Just the rubi, so sounds like to me its something with the jeep. Anybody else have this issue or any info on why its doing it?
 

·
Registered
Joined
·
10,420 Posts
What is your phone? What is your girlfriend's phone?

Jeep's Uconnect seems to follow the Bluetooth spec exactly. It doesn't expect/allow any deviations. In contrast, some phones (like Apples, which is why I asked) like to do their own thing and skip Bluetooth steps they deem unnecessary or redundant.

Aside from that, you could try to unpair and then re-pair your phone to see if it clears up the problem.
 

·
Registered
Joined
·
750 Posts
Discussion Starter · #3 ·
she had an LG when we bought it and no issues, now has a HTC One, i have Casio 4G Commando i think its called. no apple junk here lol i did try the un pair, re pair with no luck.
 

·
Commercial Member
Joined
·
2,013 Posts
Which radio do you have? Which radio is in the truck? Have you tried to reboot the phone? This usually helps with some strange things that are happening. If the phone battery is accessible, remove it for a few minutes then reinsert it. If it's not accessible then you'll need to do a factory reset.



she had an LG when we bought it and no issues, now has a HTC One, i have Casio 4G Commando i think its called. no apple junk here lol i did try the un pair, re pair with no luck.
 

·
Registered
Joined
·
750 Posts
Discussion Starter · #5 ·
i not sure the numbe rof hte radio, it was the basic set up for the rubicon.. i have the ford sync in truck, phone has been rebooted several times. this isnt a one time deal. its every time i get in jeep.
 

·
Commercial Member
Joined
·
2,013 Posts
The problem here is that the BT specs are not tightly regulated which lets the interpretation of the spec be slightly different depending on who's interpreting it. This will cause some phones to work well while others may not.

What's happening here is that there are dropped packets by the phone when streaming audio to Uconnect. There's a clock speed range that the packets need to be sent to Uconnect. If the packets are sent too fast or too slow, then there will be dropped packets. All BT car kits don't all support the identical clock speed. In this case most phones work well with the clock speed that Uconnect has which also supplies a good sound quality as well. Does this happen only when using APPS or does it also happen when you stream audio stored on the phone?




she had an LG when we bought it and no issues, now has a HTC One, i have Casio 4G Commando i think its called. no apple junk here lol i did try the un pair, re pair with no luck.
 

·
Registered
Joined
·
750 Posts
Discussion Starter · #10 ·
The problem here is that the BT specs are not tightly regulated which lets the interpretation of the spec be slightly different depending on who's interpreting it. This will cause some phones to work well while others may not.

What's happening here is that there are dropped packets by the phone when streaming audio to Uconnect. There's a clock speed range that the packets need to be sent to Uconnect. If the packets are sent too fast or too slow, then there will be dropped packets. All BT car kits don't all support the identical clock speed. In this case most phones work well with the clock speed that Uconnect has which also supplies a good sound quality as well. Does this happen only when using APPS or does it also happen when you stream audio stored on the phone?
i only use pandora so i cant say if it would do it on stored music or not
 

·
Registered
Joined
·
372 Posts
Do you have access to any music that you could store on your phone just to test it. Could help us dial in on whether the app or mobile data connection might be the cause.
 
1 - 12 of 12 Posts
Top