Jeep Wrangler Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi All,
I’ve wired in a REDARC Tow-Pro Elite trailer brake Controller into my 2014 Jeep JKU with the max tow package.
Lights work. Bake lights illuminate. Turn signals work. I assume all of these are working due to the stock four pin connection into the seven pin harness.
The blue light on the control knob light “breathes” blue when I depress the knob. All that said, the brakes are not engaging. I’ve gone through all the wiring and believe it’s all correct. The red wire from the brake controller is connected to the brake light trigger wire in the brake wiring loom just above brake pedal. It’s the white wire with tan stripe per various videos on YouTube. All instructions indicate that the wire should only carry a signal only when the brake pedal is depressed. Here’s the catch, it’s “hot” all the time. So are all the other “hot” wires in this loom. So as a result I’m not getting any actual braking power to the trailer.
I’m stumped. Any advice on what to check or where else to connect the red brake controller wire would be appreciated. I need to tow at 2500lb trailer through the mountains of WV this coming weekend. All paved roads.
Thanks!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
95 Posts
The wires in the brake switch plug do not go "hot" like a traditional switch would. The switch tells the computer you activated the brake and the computer triggers the brake lights. You need to tie into the harness going to the brake lights so that you see a 12v signal only after the computer has activated the lights. Here is a link to another thread about wiring a brake controller.

https://www.wranglerforum.com/f202/brake-light-tap-2358207.html
 
1 - 2 of 2 Posts
Top