Jeep Wrangler Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
When I apply the breaks there is a loud air noise, almost like air brakes. The pedal is extremly hard to press and every now and then it will just go soft and half way down. Do you think it is the brake booster or should I first try replacing the check valve?

Thanks
 

·
Registered
Joined
·
2,724 Posts
Sounds a lot like a vacuum issue within the booster...have you checked the vacuum line to it?
 

·
Registered
Joined
·
8,965 Posts
I don't know what year you have, but check the vac. line(s) coming off of the brake booster. You should have at least one into the check valve. It's probably cracked. Trace it back and take any of the lines to a parts store and they'll match it up. Your check valve could be bad but chances are it's a vac. line leaking.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #6 ·
Thanks, I was thinking the vacum line size would be generic and you just go by so many feet of it. I will check the line this weekend when I get the garage clean enough to actually make it to the jeep. I bought it and stuffed it in the back of the garage until I get all the christmas decoration boxes put back up.
 

·
Registered
Joined
·
3,840 Posts
The check valve pretty much just make sure the breaks do not jam on if you had a backfire in the intake!
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #8 ·
When I got home today I made my way back to the jeep. could not really see much in the garage. When I first started it I did not hear the air leak. after about a minute it was back and I did notice that when I apply breaks the idle is not as smooth.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top