Jeep Wrangler Forum banner

Broken Pin on Tail light harness connector

7736 Views 5 Replies 4 Participants Last post by  Scout About
:facepalm:

This is the dumbest thing I've done all week. In a hurry last night to change to my aftermarket tail lights, I must have incorrectly pushed the plug-n-play connectors together. There is a pin broken off on the 6 pin harness that comes from the jeep body. I'm trying to find one online since I have no left brake light or turn signal and the dealer quoted $95 for it and 4 days to get it.

What is the official name for this part? Does anyone have any suggestions on a faster fix? Here is a pic of the piece I need to replace....

p.s. the site where I found the pic was no help in case you are wondering.....

Attachments

1 - 6 of 6 Posts

· Premium Member
Joined
·
240 Posts
Are all of pins connected to a wire? If not maybe there is a way to remove the unused pin and substitute it for the broken one???
 

· Registered
Joined
·
10,442 Posts

· Registered
Joined
·
40 Posts
Discussion Starter · #6 ·
I have to post my stupidity here so if anyone else should find themselves in this situation, you will know what to do.

It wasn't the pin. I thought I had broken one off but it was supposed to be like that. I discovered this after I bought a new one.

Turns out the light was bad. I sent it back to the vendor and they gave me a replacement which plugged in fine and has worked great every since.

I'm a dumba**
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top